archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deng Ching <och...@apache.org>
Subject Re: Cannot download SNAPSHOT from Archiva when listed as dependency
Date Wed, 19 Sep 2012 08:55:07 GMT
Yep, the repository id should match the server id and the one in mirrorOf.
Sorry, https was a typo in my part, should be just http if you're not
running Archiva in secured protocol. Can you paste the snippet of the build
output when you got the error?

Thanks,
Deng

On Wed, Sep 19, 2012 at 12:22 PM, Harris, Christopher P <
chris_harris@baxter.com> wrote:

> Hi, Deng.
>
> That partially worked for me.  I had to modify it though.
>         <server>
>         <id>repo-snapshots</id>
>         <username>admin</username>
>         <password>password</password>
>       </server>
>
>         "external:*" has never worked for me.  "*" works for me.
>
>     <mirror>
>       <id>some_id</id>
>       <url>http://localhost:8083/archiva/repository/group_id/</url>
>       <mirrorOf>*,!repo-snapshots</mirrorOf>
>     </mirror>
>
>         It seems that when I removed the 's' in "https", I was able to
> successfully download the .pom and meta-data.xml files.  I couldn't
> download the .jar's though.
>
>     <profile>
>       <id>repo-snapshots</id>
>       <activation>
>         <activeByDefault>true</activeByDefault>
>       </activation>
>       <repositories>
>         <repository>
>           <id>repo-snapshots</id>
>           <name>repo-snapshots</name>
>           <url>http://localhost:8083/archiva/repository/repo-snapshots/
> </url>
>           <releases>
>             <enabled>false</enabled>
>           </releases>
>           <snapshots>
>             <enabled>true</enabled>
>           </snapshots>
>          </repository>
>        </repositories>
>     </profile>
>
>         I take it something in profile is supposed to match something in
> the mirror and server sections?
>
> I received a "could not resolve dependency" error when compiling my test
> project.
>
>  - Chris Harris
>
> -----Original Message-----
> From: odeaching@gmail.com [mailto:odeaching@gmail.com] On Behalf Of Deng
> Ching
> Sent: Tuesday, September 18, 2012 10:39 PM
> To: users@archiva.apache.org
> Subject: Re: Cannot download SNAPSHOT from Archiva when listed as
> dependency
>
> Hi Chris,
>
> You need to add the snapshots repo as follows:
>
> <profile>
>       <id>snapshots-profile</id>
>       <activation>
>         <activeByDefault>true</activeByDefault>
>       </activation>
>       <repositories>
>         <repository>
>           <id>snapshots.repo</id>
>           <name>Your Snapshots Repo</name>
>           <url>https://archiva.repo/archiva/repository/snapshots</url>
>           <releases>
>             <enabled>false</enabled>
>           </releases>
>           <snapshots>
>             <enabled>true</enabled>
>           </snapshots>
>          </repository>
>        </repositories>
> </profile>
>
> Then change <mirrorOf> to:
>
> <mirrorOf>external:*,!snapshots.repo</mirrorOf>
>
>  HTH,
> Deng
>
> On Wed, Sep 19, 2012 at 7:23 AM, Harris, Christopher P <
> chris_harris@baxter.com> wrote:
>
> > Hi,
> >
> > I've done several hours worth of searching and experimenting for a
> > resolution to this problem with no luck:
> > I've created an managed repo to house in-house snapshots along with some
> > special 3rd-party snapshots.  I cannot download 2 3rd-party snapshots.
> >
> > I get these 2 error messages:
> > The POM for org.apache.myfaces.tomahawk:tomahawk12:jar:1.1.14-SNAPSHOT is
> > missing, no dependency information available
> > The POM for
> > org.apache.myfaces.tomahawk:tomahawk-sandbox12:jar:1.1.14-SNAPSHOT is
> > missing, no dependency information available
> >
> > My settings.xml:
> >
> > <mirror>
> >       <id>some_id</id>
> >       <url>http://localhost:8083/archiva/repository/repo_group_name/
> </url>
> >       <mirrorOf>*</mirrorOf>
> > </mirror>
> >
> > I've tried adding an active-by-default profile to my snapshots repo, but
> > that didn't work.
> >
> > To upload the .jar & .pom files, I've copied them from my local Maven
> repo
> > to my C:\ and then uploaded the snapshots via command prompt:
> >
> > C:\>mvn deploy:deploy-file -Dfile=tomahawk12-1.1.14-SNAPSHOT.jar
> > -DpomFile=tomah
> > awk12-1.1.14-SNAPSHOT.pom -DrepositoryId=repo-snapshots -Durl=
> > http://localhos
> > t:8083/archiva/repository/repo-snapshots/ -DuniqueVersion=false
> > -DupdateRelea
> > seInfo=true
> >
> > Note that deploy:deploy-file only works using artifacts not in my local
> > Maven repo.  That's why I move them to C:\
> >
> > I originally tried uploading without uniqueVersion and updateReleaseInfo.
> >  No luck either.
> >
> > I opened up a simple tester project in NetBeans and added these 2
> > dependencies.  Sure enough, when I type in <version></version> and hit
> Ctrl
> > + the space bar, I see 1.1.14-SNAPSHOT listed as a hint.  I can also
> access
> > the pom and jar in Archiva from my browser.
> >
> > How can I download snapshot dependencies from Archiva?
> >
> >
> > -    Chris Harris
> The information transmitted is intended only for the person(s)or entity to
> which it is addressed and may contain confidential and/or legally
> privileged material. Delivery of this message to any person other than the
> intended recipient(s) is not intended in any way to waive privilege or
> confidentiality. Any review, retransmission, dissemination or other use of
> , or taking of any action in reliance upon, this information by entities
> other than the intended recipient is prohibited. If you receive this in
> error, please contact the sender and delete the material from any computer.
>
> For Translation:
>
> http://www.baxter.com/email_disclaimer
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message