archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: Archiva indexes for multiple repo groups/3rd party proxies...
Date Tue, 07 Aug 2012 20:19:06 GMT
We need more debug logs to try understand (or have access to your server :-) )
Can you change log4j.xml file and add

  <!-- apache httpclient debug content transfer-->
  <logger name="org.apache.http.wire">
    <level value="debug"/>
  </logger>

  <logger name="org.apache.http.headers">
    <level value="debug"/>
  </logger>

That will be a bit verbose but we will have more details.


2012/8/7 Jeff <predatorvi@gmail.com>:
> Any other thoughts as to why this might not work for me?  I really want the
> indexes! :-)
>
> On Mon, Jul 30, 2012 at 4:38 PM, Jeff <predatorvi@gmail.com> wrote:
>
>> Could it be that Archiva needs to set more HTTP header values (e.g.,
>> "Accept: ...") when requesting these files?  Here is a dump of what I see
>> with Archiva vs. Chrome.
>>
>> ARCHIVA HTTP Request:
>>
>> GET /maven2/.index/nexus-maven-repository-index.properties HTTP/1.1
>> Cache-control: no-cache
>> Cache-store: no-store
>> Pragma: no-cache
>> Expires: 0
>> Accept-Encoding: gzip
>> Host: repo.maven.apache.org
>> Connection: Keep-Alive
>>
>>
>> CHROME BROWSER HTTP Request:
>>
>> GET /maven2/.index/nexus-maven-repository-index.properties HTTP/1.1
>> Host: central.maven.org
>> Connection: keep-alive
>> User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML,
>> like Gecko) Chrome/20.0.1132.57 Safari/536.11
>> Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
>> Accept-Encoding: gzip,deflate,sdch
>> Accept-Language: en-US,en;q=0.8
>> Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3
>>
>>
>>
>> On Mon, Jul 30, 2012 at 2:57 PM, Olivier Lamy <olamy@apache.org> wrote:
>>
>>> 2012/7/30 Jeff <predatorvi@gmail.com>:
>>> > I've been fiddling and noticed that when it tries to connect to the
>>> Maven
>>> > Central index location at
>>> >
>>> http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.propertiesI
>>> > see:
>>> >
>>> > 2012-07-30 14:44:20,825 [taskScheduler#indexDownloadRemote-4] INFO
>>> >
>>>  org.apache.archiva.scheduler.indexing.DownloadRemoteIndexTask$DownloadListener
>>> >  - error of transfer file [nexus-maven-repository-index.properties,
>>> Access
>>> > denied to:
>>> >
>>> http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties
>>> ,
>>> > ReasonPhrase:Forbidden.]:
>>> > org.apache.maven.wagon.authorization.AuthorizationException: Access
>>> denied
>>> > to:
>>> >
>>> http://repo1.maven.org/maven2/.index/nexus-maven-repository-index.properties
>>> ,
>>> > ReasonPhrase:Forbidden.
>>>
>>> weird.
>>> Works fine here.
>>> Note I use:
>>> http://repo.maven.apache.org/maven2/.index/nexus-maven-repository-index.properties
>>>
>>> curl -I
>>> http://repo.maven.apache.org/maven2/.index/nexus-maven-repository-index.properties
>>> HTTP/1.1<http://repo.maven.apache.org/maven2/.index/nexus-maven-repository-index.propertiesHTTP/1.1>200
OK
>>> Accept-Ranges: bytes
>>> Content-Type: application/octet-stream
>>> Date: Mon, 30 Jul 2012 20:56:36 GMT
>>> Last-Modified: Sun, 15 Jul 2012 10:54:57 GMT
>>> Server: ECAcc (cdg/D67A)
>>> X-Cache: HIT
>>> Content-Length: 1130
>>>
>>> Do you pass tru a proxy or something else (firewall) ?
>>>
>>> >
>>> >
>>> > However, when I go to that URL directly or do a wget from the Archiva
>>> > server, it downloads just fine.
>>> >
>>> > Any idea why?
>>> >
>>> > On Mon, Jul 30, 2012 at 11:17 AM, Olivier Lamy <olamy@apache.org>
>>> wrote:
>>> >
>>> >> 2012/7/26 Jeff <predatorvi@gmail.com>:
>>> >> > In my NetBeans environment, it pulls the Maven indexes and gives
me
>>> hints
>>> >> > when I <CTRL>-<SPACE> on versions or artifact ID's,
etc.
>>> >> >
>>> >> > However, it seems that the indexes that NetBeans pulls from my
>>> Archiva
>>> >> > server is not handling all of the indexes for all of my repositories
>>> like
>>> >> > it used to and I don't know what I've done wrong.
>>> >> >
>>> >> > I have 6 managed repositories:
>>> >> >
>>> >> >    - 3rd-party-releases
>>> >> >    - 3rd-party-snapshots
>>> >> >    - team1-releases
>>> >> >    - team1-snapshots
>>> >> >    - team2-releases
>>> >> >    - team2-snapshots
>>> >> >
>>> >> > I also have 16 remote repositories.  Some of them are "release"
>>> >> > repositories (central, java.net, etc.) that are connected via proxy
>>> to
>>> >> the
>>> >> > "3rd-party-releases" managed repo.  Some are remote snapshot repos
>>> that
>>> >> are
>>> >> > proxied to the "3rd-party-snapshots" managed repo.
>>> >> >
>>> >> > I then have one repository group that contains all 6 managed repos.
>>> >> >
>>> >> > I have defined explicit index directories for each managed
>>> repository as
>>> >> > well as the remote repos.
>>> >> >
>>> >> > For all remote repositories, I have checked "Activate download
remote
>>> >> > index", attempted to specify the "Remote index url" (for Central
it
>>> is
>>> >> set
>>> >> > to .index), but some don't seem to generate indexes.
>>> >> Are you sure remote repositories generate an index file ?
>>> >>
>>> >> BTW with 1.4-M2 there is now an aggregated indice file in your group.
>>> >>
>>> >> >
>>> >> > However, it seems to not contain all of the versions of the
>>> artifacts.
>>> >> >
>>> >> > Did I set up my repo wrong or is it something else?  I don't know
>>> where
>>> >> to
>>> >> > look?
>>> >> >
>>> >> > Thanks!
>>> >> >
>>> >> > --
>>> >> > Jeff Vincent
>>> >> > predatorvi@gmail.com
>>> >> > See my LinkedIn profile at:
>>> >> > http://www.linkedin.com/in/rjeffreyvincent
>>> >> > I ♥ DropBox <http://db.tt/9O6LfBX> !!
>>> >>
>>> >>
>>> >>
>>> >> --
>>> >> Olivier Lamy
>>> >> Talend: http://coders.talend.com
>>> >> http://twitter.com/olamy | http://linkedin.com/in/olamy
>>> >>
>>> >
>>> >
>>> >
>>> > --
>>> > Jeff Vincent
>>> > predatorvi@gmail.com
>>> > See my LinkedIn profile at:
>>> > http://www.linkedin.com/in/rjeffreyvincent
>>> > I ♥ DropBox <http://db.tt/9O6LfBX> !!
>>>
>>>
>>>
>>> --
>>> Olivier Lamy
>>> Talend: http://coders.talend.com
>>> http://twitter.com/olamy | http://linkedin.com/in/olamy
>>>
>>
>>
>>
>> --
>> Jeff Vincent
>> predatorvi@gmail.com
>> See my LinkedIn profile at:
>> http://www.linkedin.com/in/rjeffreyvincent
>> I ♥ DropBox <http://db.tt/9O6LfBX> !!
>>
>>
>
>
> --
> Jeff Vincent
> predatorvi@gmail.com
> See my LinkedIn profile at:
> http://www.linkedin.com/in/rjeffreyvincent
> I ♥ DropBox <http://db.tt/9O6LfBX> !!



-- 
Olivier Lamy
Talend: http://coders.talend.com
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
View raw message