archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: Lost into archiva and snapshot policy
Date Fri, 30 Mar 2012 13:13:35 GMT
Hello,
Could write a sample project/pom with the dependencies and the
relevant part of your archiva.xml and share that ?
Will be more easy to test .
Thanks,
--
Olivier

2012/3/30 Eric Barboni <barboni@irit.fr>:
> Hi , thanks for the help, I try your approach but was not so successfull.
>
> I have delete all .lastUpdated stuff and hidden file to be sure.
>
> I have the following log for example with maven 3.0.4 run from a netbeans:
> <<
> Could not find metadata
> org.netbeans.api:org-openide-loaders:SNAPSHOT/maven-metadata.xml in local
> (C:\Users\Didier\.m2\repository)
> Using connector WagonRepositoryConnector with priority 0 for
> http://setekh.irit.fr/archiva/repository/mirror/ as test
> Downloading:
> http://setekh.irit.fr/archiva/repository/mirror/org/netbeans/api/org-openide
> -loaders/SNAPSHOT/maven-metadata.xml
>
> Downloaded:
> http://setekh.irit.fr/archiva/repository/mirror/org/netbeans/api/org-openide
> -loaders/SNAPSHOT/maven-metadata.xml (366 B at 0.2 KB/sec)
> Writing resolution tracking file
> C:\Users\Didier\.m2\repository\org\netbeans\api\org-openide-loaders\SNAPSHOT
> \resolver-status.properties
> Using connector WagonRepositoryConnector with priority 0 for
> http://setekh.irit.fr/archiva/repository/mirror/ as test
> Downloading:
> http://setekh.irit.fr/archiva/repository/mirror/org/netbeans/api/org-openide
> -loaders/SNAPSHOT/org-openide-loaders-20120328.135230-1.pom
>
> Writing resolution tracking file
> C:\Users\Didier\.m2\repository\org\netbeans\api\org-openide-loaders\SNAPSHOT
> \org-openide-loaders-20120328.135230-1.pom.lastUpdated
> The POM for org.netbeans.api:org-openide-loaders:jar:20120328.135230-1 is
> missing, no dependency information available
>>>
>
> Into the archiva filesystem  for the snapshots repository
> I have metadata.xml present  but no trace of a
> org-openide-loaders-20120328.135230-1.pom.
>
> Not log at all on archiva side :s
>
>
>
>
>
>
>
>
>
>
> -----Message d'origine-----
> De : odeaching@gmail.com [mailto:odeaching@gmail.com] De la part de Deng
> Ching
> Envoyé : vendredi 30 mars 2012 05:22
> À : users@archiva.apache.org
> Objet : Re: Lost into archiva and snapshot policy
>
> Hi Eric,
>
> You need to add a <repository> configuration in an activated profile, with
> <snapshots> set to true, to be able to download snapshots from the
> repository.
>
> Ex.
> <settings>
>  <mirrors>
>  ...
>  </mirrors>
>  <servers>
>  ...
>  </servers>
>  <profiles>
>    <profile>
>      <id>snapshots</id>
>      <activation>
>        <activeByDefault>true</activeByDefault>
>      </activation>
>      <name>snapshots.repo</name>
>      <url>http://setekh.irit.fr/archiva/repository/mirror/</url>
>      <releases>
>        <enabled>false</enabled>
>      </releases>
>      <snapshots>
>        <enabled>true</enabled>
>      </snapshots>
>    </profile>
>  </profiles>
> </settings>
>
> Thanks,
> Deng
>
> On Thu, Mar 29, 2012 at 7:55 PM, Eric Barboni <barboni@irit.fr> wrote:
>
>> Hi folks,
>>
>>
>>
>> I have some trouble understanding how to configure archiva with
>> snapshot repository.
>>
>>
>>
>>
>>
>> My archiva with a repository group configured like this:
>>
>> mirror (internal,snapshots,ics_snapshots,ics_internal)
>>
>> in the snapshots repository I have several snapshots repo including (
>> netbeans-snapshot,apache.snapshots,codehaus-snaphots.)
>>
>> I use the following in the settings.xml:
>>
>> <mirror>
>>
>>   <id>mirror</id>
>>
>>            <name>Proxy Cache - Internal Repository</name>
>>
>>            <url>http://setekh.irit.fr/archiva/repository/mirror/</url>
>>
>>            <mirrorOf>*</mirrorOf>
>>
>>        </mirror>
>>
>>
>>
>> Trying to build I have the following error:
>>
>>
>>
>> Could not find metadata
>> org.netbeans.api:org-openide-loaders:SNAPSHOT/maven-metadata.xml in
>> local
>>
>> Could not find metadata
>> org.netbeans.api:org-openide-loaders:SNAPSHOT/maven-metadata.xml in
>> local
>>
>> The POM for org.netbeans.api:org-openide-loaders:jar:SNAPSHOT is
>> missing, no dependency information available
>>
>>
>>
>> The metadata file on the server are up to date.
>>
>> But no file are uploaded (no jar, no pom).
>>
>>
>>
>> Archiva log nothing wrong so I am bit lost.
>>
>>
>>
>> Any help appreciated.
>>
>>
>>
>> (Normaly I use netbeans release version, but I try things for 1.4-M3
>> and browse page)
>>
>>
>>
>> Regards
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>



-- 
Olivier Lamy
Talend: http://coders.talend.com
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
View raw message