archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Barboni" <barb...@irit.fr>
Subject Lost into archiva and snapshot policy
Date Thu, 29 Mar 2012 11:55:50 GMT
Hi folks,

 

I have some trouble understanding how to configure archiva with snapshot
repository.

 

 

My archiva with a repository group configured like this:

mirror (internal,snapshots,ics_snapshots,ics_internal)

in the snapshots repository I have several snapshots repo including (
netbeans-snapshot,apache.snapshots,codehaus-snaphots.)

I use the following in the settings.xml:

<mirror>        

   <id>mirror</id>

            <name>Proxy Cache - Internal Repository</name>

            <url>http://setekh.irit.fr/archiva/repository/mirror/</url>

            <mirrorOf>*</mirrorOf>

        </mirror>

 

Trying to build I have the following error:

 

Could not find metadata
org.netbeans.api:org-openide-loaders:SNAPSHOT/maven-metadata.xml in local 

Could not find metadata
org.netbeans.api:org-openide-loaders:SNAPSHOT/maven-metadata.xml in local 

The POM for org.netbeans.api:org-openide-loaders:jar:SNAPSHOT is missing, no
dependency information available

 

The metadata file on the server are up to date.

But no file are uploaded (no jar, no pom). 

 

Archiva log nothing wrong so I am bit lost. 

 

Any help appreciated. 

 

(Normaly I use netbeans release version, but I try things for 1.4-M3 and
browse page)

 

Regards

 

 

 

 

 

 

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message