archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szelag, Lukasz" <lukasz.sze...@baml.com>
Subject Access denied for a user in a Global Repository Manager role (Archiva 1.3.5)
Date Fri, 21 Oct 2011 19:24:01 GMT
I'm getting below access denied error when trying to connect to Archiva from Maven using a
user in a Global Repository Manager role:

Archiva log:

--------
2011-10-21 15:04:43,917 ["http-apr-8080"-exec-2] ERROR org.apache.maven.archiva.webdav.ArchivaDavResourceFactory
 - Failures occurred downloading from some remote repositories:
	central: Download failure on resource [http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom]:Access
denied to: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom
--------

Maven log:

--------
Downloading: http://<hostname>:8080/archiva/repository/external-releases/org/codehaus/mojo/mojo-parent/20/mojo-parent-20.pom
[WARNING] Unable to get resource 'org.codehaus.mojo:mojo-parent:pom:20' from repository external-releases
(http://<hostname>:8080/archiva/repository/external-releases): Error transferring file:
Server returned HTTP response code: 500 for URL: http://<hostname>:8080/archiva/repository/external-releases/org/codehaus/mojo/mojo-parent/20/mojo-parent-20.pom
--------

Checklist:

1) The user in question is granted the Global Repository Manager role
2) I'm able to login to Archiva Web interface as the given user
3) Maven settings.xml properly reference user's credentials and associate it with the correct
repository
4) The direct URL works (http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom)

Archiva is running on Tomcat 7.0.12 on Windows.

The above "external-releases" repository is defined as a proxy connector for 3 remote repositories,
including Maven Central Repository where the artifact in question resides.

This looks like a bug but perhaps I'm missing something. Does anyone know what could be the
problem?

Thanks,
Lukasz


----------------------------------------------------------------------
This message w/attachments (message) is intended solely for the use of the intended recipient(s)
and may contain information that is privileged, confidential or proprietary. If you are not
an intended recipient, please notify the sender, and then please delete and destroy all copies
and attachments, and be advised that any review or dissemination of, or the taking of any
action in reliance on, the information contained in or attached to this message is prohibited.

Unless specifically indicated, this message is not an offer to sell or a solicitation of any
investment products or other financial product or service, an official confirmation of any
transaction, or an official statement of Sender. Subject to applicable law, Sender may intercept,
monitor, review and retain e-communications (EC) traveling through its networks/systems and
may produce any such EC to regulators, law enforcement, in litigation and as required by law.

The laws of the country of each sender/recipient may impact the handling of EC, and EC may
be archived, supervised and produced in countries other than the country in which you are
located. This message cannot be guaranteed to be secure or free of errors or viruses. 

References to "Sender" are references to any subsidiary of Bank of America Corporation. Securities
and Insurance Products: * Are Not FDIC Insured * Are Not Bank Guaranteed * May Lose Value
* Are Not a Bank Deposit * Are Not a Condition to Any Banking Service or Activity * Are Not
Insured by Any Federal Government Agency. Attachments that are part of this EC may have additional
important disclosures and disclaimers, which you should read. This message is subject to terms
available at the following link: 
http://www.bankofamerica.com/emaildisclaimer. By messaging with Sender you consent to the
foregoing.

Mime
View raw message