archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff <predato...@gmail.com>
Subject New to archiva and it's kicking my butt...
Date Wed, 31 Aug 2011 20:21:10 GMT
Running on Windows Server 2008 R2 sp1 x64.

I'm sure the issue will turn out to be a n00b mistake, but ...

I am trying to just run the standalone and get it working.  I'll try it as a
WAR later.  My settings are:

Archiva files at:  C:\WebApps\archiva-1.3.5
JAVA_HOME=C:\Program Files\Java\jre6
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;
*C:\WebApps\archiva-1.3.5\bin\*

C:\WebApps\archiva-1.3.5>java -version

java version "1.6.0_27"
Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)


Steps (with output):

C:\WebApps\archiva-1.3.5>*java -version*
*java version "1.6.0_27"
Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)*
C:\WebApps\archiva-1.3.5>*path*
*
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\WebApps\archiva-1.3.5\bin\
*
C:\WebApps\archiva-1.3.5>*bin\archiva.bat install
**wrapper  | Apache Archiva installed.*
C:\WebApps\archiva-1.3.5>*bin\archiva.bat start
**wrapper  | Starting the Apache Archiva service...
wrapper  | The Apache Archiva service was launched, but failed to start.
Press any key to continue . . .*


wrapperXXX.log content:

STATUS | wrapper  | 2011/08/31 14:09:31 | Starting the Apache Archiva
service...
STATUS | wrapper  | 2011/08/31 14:09:31 | --> Wrapper Started as Service
STATUS | wrapper  | 2011/08/31 14:09:31 | Launching a JVM...
FATAL  | wrapper  | 2011/08/31 14:09:31 | *Unable to execute Java command.
The system cannot find the file specified. (0x2)*
FATAL  | wrapper  | 2011/08/31 14:09:31 |     "java" -Dappserver.home=.
-Dappserver.base=. -Djetty.logs=./logs -Djava.library.path="lib" -classpath
"lib/wrapper.jar;lib/archiva-jetty-1.3.5.pom;lib/jetty-6.1.19.jar;lib/jetty-util-6.1.19.jar;lib/servlet-api-2.5-20081211.jar;lib/start-6.1.19.jar;lib/jetty-naming-6.1.19.jar;lib/jsp-2.1-jetty-6.1.19.jar;lib/core-3.1.1.jar;lib/jsp-api-2.1-glassfish-9.1.1.B60.25.p0.jar;lib/jsp-2.1-glassfish-9.1.1.B60.25.p0.jar;lib/jetty-plus-6.1.19.jar;lib/geronimo-spec-jta-1.0.1B-rc4.jar;lib/derby-10.1.3.1.jar;lib/mail-1.4.jar;lib/activation-1.1.jar;lib/ant-1.6.5.jar;lib/commons-dbcp-1.2.1.jar;lib/commons-collections-3.2.jar;lib/commons-pool-1.2.jar;lib/xml-apis-1.0.b2.jar;lib/xercesImpl-2.8.1.jar"
-Dwrapper.key="TFFp8XlxVgaOBniO" -Dwrapper.port=32000
-Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=3132
-Dwrapper.version="3.2.3" -Dwrapper.native_library="wrapper"
-Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="10" -Dwrapper.jvmid=1
org.tanukisoftware.wrapper.WrapperSimpleApp org.mortbay.start.Main
./conf/jetty.xml
FATAL  | wrapper  | 2011/08/31 14:09:31 | Critical error: wait for JVM
process failed
ERROR  | wrapper  | 2011/08/31 14:09:33 | The Apache Archiva service was
launched, but failed to start.

I'm not sure what file it can't find.  It can find java.exe as well as the
wrapperXXX.exe.  If there is something else I need to tweak, I'm unable to
find it in the docs.

I get the same result starting with the 'console' parameter'.

Thanks in advance for any help!

-- 

Jeff Vincent
predatorvi@gmail.com
See my LinkedIn profile at:
http://www.linkedin.com/in/rjeffreyvincent
 I ♥ DropBox <http://db.tt/9O6LfBX> !!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message