archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: Delete failure
Date Fri, 26 Aug 2011 18:06:13 GMT
On Fri, Aug 26, 2011 at 1:47 PM, Dan Armbrust
<daniel.armbrust.list@gmail.com> wrote:

> Anyway, feature requests are beside the point.  Normally the delete
> works for me.  However, this time, while it reported that the delete
> was successful, it in fact was not, according to the browser - as the
> item still appeared.

What url?  If it was a /browse/ url, it's possible the database hadn't
been updated it would show without actually being there.

Did you happen to check the file system to know for sure whether it
was actually gone?

> So, I tried to delete it again, which ended badly:
> Problem accessing /archiva/deleteArtifact!doDelete.action. Reason:
>    INTERNAL_SERVER_ERROR
> Caused by:
>
> java.lang.NullPointerException

In any case, it shouldn't do that.  Are you able to reproduce it?  In
the past when I've tried to delete something that's not there, I just
got an error message.  What version of Archiva are you using, in case
someone wants to try?

(The rest of your post has some feature requests.  If you have time it
would be great to make sure those are in JIRA.  I think some of them
are already.)

-- 
Wendy

Mime
View raw message