archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Uploading large files?
Date Tue, 16 Aug 2011 13:58:35 GMT

On 03/08/2011, at 3:49 AM, Dan Armbrust wrote:
> However, when I try to upload a large file, I get the broken pipe at
> an arbitrary point, and the server reports:
> 
> myip -  -  [02/Aug/2011:17:02:27 +0000] "PUT
> /archiva/repository/apelon-data//com/apelon/va/ihtsdo/wb/snomed/snomed-data/2010.07.31-build1-sct-en-vtmvmp-non-human-2-versioni-junk/snomed-data-2010.07.31-build1-sct-en-vtmvmp-non-human-2-versioni-junk.zip
> HTTP/1.1" 401 0 "-" "Apache-Maven/2.2 (Java 1.6.0_25; Linux
> 2.6.31-23-generic) maven-artifact/2.2.1"
> 
> And also:
> 2011-08-02 13:02:27,500 [btpool0-39] INFO
> org.apache.maven.archiva.security.ArchivaServletAuthenticator  -
> Authorization Denied
> [ip=myip,permission=archiva-upload-repository,repo=apelon-data] : no
> matching permissions

This is likely not what it looks like - there's usually one of these first as the request
is sent without credentials, then in response to the 401 the credentials are sent. There's
some discussion about using preemptive auth here: http://jira.codehaus.org/browse/WAGON-277,
and there's been a bit of recent work on Wagon that is not yet included in released Maven.

The other deployment method you can try is dav:http://.… with an extension added for wagon-webdav-jackrabbit
1.0.

Regards,
Brett

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter





Mime
View raw message