archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Armbrust <daniel.armbrust.l...@gmail.com>
Subject Re: browse not showing all groups?
Date Tue, 24 May 2011 13:06:20 GMT
On Wed, May 18, 2011 at 7:12 PM, Brett Porter <brett@apache.org> wrote:
>
> On 18/05/2011, at 4:43 AM, Dan Armbrust wrote:
>
>>>> Database -> Update Database Now
>>>> Repositories -> Scan Repository Now (with process all checked)
>>>> And just basic hard-refreshes through the browser, to make sure it
>>>> isn't a browser-cache issue.
>>>
>>> I believe those need to be done in reverse order.  (Though if you did
>>> it more than once, the second 'update database' should have caught
>>> what the scan turned up.)
>>>
>>
>>
>> Is there supposed to be some sort of feedback when I click those buttons?
>>
>> The submit seems to go through, but there is no feedback at all.
>
> It goes into a queue, which you can see on the queue page.


I don't see it there... but I think it happens so fast on this small
repository, that it is gone before I get there.

The last scanned time stamp seems reasonable.

>> Funny thing is, IIRC, it did work the first time I uploaded this
>> artifact.  But then, (after a very long time, due to the size of the
>> file) it decided to reject my upload, because it didn't like my
>> version number.  Sigh.  So many bugs in that version number
>> algorithm.... it should just be turned off if you ask me.
>>
>> So I did a delete, tried again.  Ran into another bug in the version
>> number verification... did a delete, tried again.  Finally found a
>> version number that it wouldn't reject.  But by then, the group had
>> vanished from the browser, and has never returned.
>>
>> Probably related to this sequence of events... I guess I could try to
>> reproduce it with a smaller file.  But first I'd need to set up a
>> local install that I can completely administer.  Too little time, at
>> the moment.
>
> That sounds quite strange. The instructions Wendy provided are complete - the only thing
I can think of is that you are uploading some form of POM along with the artifact (or generating
it)?
>
> Does the extension of the artifact in question in exist in the "artifacts" list on the
"repository scanning page"?
>
> - Brett

Just uploaded a zip file.  And zip is still in the extensions list.  I
let it generate the pom - and when I browse it in the webdav view, it
all seems correct.  It made the pom, and it generated all the checksum
files, and the maven-metadata file.

I keep hoping it will magically fix itself... but so far, no luck.

I've uploaded another unrelated file since then (to a different path),
and it worked fine.  Just seems to be an issue with this specific
path.

I'll keep poking at this nuisance once in a while.  It's just low on
my priority list, since it more or less works at the moment.  And it
doesn't help that I don't have direct access to the system.

Mime
View raw message