archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mjk <mj.kelle...@gmail.com>
Subject Re: org.apache.maven.archiva.security.ArchivaServletAuthenticator - Authorization Denied
Date Thu, 10 Mar 2011 13:02:06 GMT
I upgraded to the newer 3.0.3 version and this now works.

On Thu, Mar 10, 2011 at 7:44 AM, mjk <mj.kelleher@gmail.com> wrote:

> I checked my local maven repo, and every single version is non-zero length.
>
> Maven 3.0-SNAPSHOT-0.10.2.20100623-1649
>
> Here is the header of my POM file:
>
> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
> http://www.w3.org/2001/XMLSchema-instance"
>     xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>     <modelVersion>4.0.0</modelVersion>
>
>
> On Thu, Mar 10, 2011 at 12:46 AM, Deng Ching <oching@apache.org> wrote:
>
>> Can you check if the POM file installed in your local repository is
>> also not zero in length? Also, what version of Maven are you using?
>> I'm not sure if this is a Maven or an Archiva problem.
>>
>> Thanks,
>> Deng
>>
>> On Thu, Mar 10, 2011 at 1:36 PM, mjk <mj.kelleher@gmail.com> wrote:
>> > Also, using WireShark, I can see maven issuing the HTTP PUT, and Archiva
>> > responding with a: "HTTP/1.1 201 Created".  Maven thinks it uploaded the
>> > file (~ 13k), but Archiva only creates an empty file, and does not put
>> the
>> > contents of the file uploaded by Maven into it.
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message