archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Mylonas <ch...@opencsta.org>
Subject Re: Authorization Denied for archiva-read-repository permission from maven
Date Wed, 09 Feb 2011 21:34:02 GMT
Ah ha!
Yep it's a typo - pg 61 of the Packt book (pg 78 in PDF form) has
.m2/conf/settings.xml

So it deploys now... no need to use plain text password.

Thanks for that, and apart from the typo, excellent book Brett.  I've
skimmed the whole lot and now slowly working my way through it - I'm moving
my development from a bunch of ant scripts and manual moving of jar
dependencies to maven - I'm looking forward to moving the opencsta project
into the 21st century (and new website)!

Cheers from Sydney
Chris

On Thu, Feb 10, 2011 at 12:33 AM, Brett Porter <brett@apache.org> wrote:

>
>
> On 09/02/2011, at 5:30 PM, Chris Mylonas wrote:
>
> > 2.  I've set my user password in the ~/.m2/conf/settings.xml file like so
>
> Is this a typo? It should be ~/.m2/settings.xml. You can use mvn
> help:effective-settings to confirm.
>
> >
> > <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
> >  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> >  xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
> >                      http://maven.apache.org/xsd/settings-1.0.0.xsd">
> >  <localRepository/>
> >  <interactiveMode/>
> >  <usePluginRegistry/>
> >  <offline/>
> >  <pluginGroups/>
> >  <servers>
> >    <server>
> >      <id>snapshots</id>
> >      <username>username4chris</username>
> >      <password>{xxxxencyptedpasswordxxxx=}</password>
> >    </server>
> >  </servers>
> >  <mirrors/>
> >  <proxies/>
> >  <profiles/>
> >  <activeProfiles/>
> > </settings>
>
> You might try the plaintext password in here first to make sure that's
> working right, then try the encrypted one.
>
> >
> > 3.  My pom.xml file has the distribution management set correctly I'm
> > presuming otherwise the mvn deploy output would be going to the wrong
> url.
>
> Make sure the ID is "snapshots" to map to above.
>
> - Brett
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message