archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Knoth <kn...@mpdl.mpg.de>
Subject Re: 100 %cpu usage
Date Mon, 14 Feb 2011 11:09:40 GMT
Hi,

That's the request log from 11. februrary in this time where i got the
problem. There are only some monitoring requests from nagios and opennms.

I run it on Jetty standalone.

134.76.28.224 -  -  [11/Feb/2011:11:53:45 +0000] "GET /archiva/
HTTP/1.1" 302 0 "-" "check_http/v1.4.15 (nagi
os-plugins 1.4.15)"
134.76.28.224 -  -  [11/Feb/2011:11:56:06 +0000] "GET /archiva/
HTTP/1.1" 302 0 "-" "-"
134.76.28.212 -  -  [11/Feb/2011:11:56:06 +0000] "GET / HTTP/1.0" 404
786 "-" "-"
null -  -  [11/Feb/2011:11:56:18 +0000] "GET /opennms/index.jsp
HTTP/1.0" 404 1285 "-" "-"
null -  -  [11/Feb/2011:11:56:18 +0000] "GET /opennms/index.jsp
HTTP/1.0" 404 1285 "-" "-"
null -  -  [11/Feb/2011:11:56:18 +0000] "GET /opennms/index.jsp
HTTP/1.0" 404 1285 "-" "-"
134.76.28.212 -  -  [11/Feb/2011:11:57:37 +0000] "GET / HTTP/1.1" 404
786 "-" "OpenNMS HttpMonitor"
134.76.28.224 -  -  [11/Feb/2011:11:57:46 +0000] "GET /archiva/
HTTP/1.1" 302 0 "-" "OpenNMS HttpMonitor"
134.76.28.224 -  -  [11/Feb/2011:11:58:45 +0000] "GET /archiva/
HTTP/1.1" 302 0 "-" "check_http/v1.4.15 (nagi
os-plugins 1.4.15)"

If i use archiva dump on 100 cpu usage it creates a dump of the java
process with a high pid. This process runs normally with 0 % cpu and 4.9
% Mem. But if i restart archiva and make a dump with archiva dump i
didn't found a second java process on top.
What should i do with the dump of archiva?

At the same time in meantime there are using max. 5 people archiva at
the same time.

Best regards

Benjamin

Am 12.02.2011 02:05, schrieb Brett Porter:
> 
> On 12/02/2011, at 12:37 AM, Benjamin Knoth wrote:
> 
>> Hi,
>>
>> I restarted on 11:06.
>>
>> On 11:56 i got this messages.
>>
>> 2011-02-11 11:56:05,101 [btpool0-6] INFO
>> org.codehaus.plexus.redback.struts2.in
>> terceptor.ForceAdminUserInterceptor  - Admin user found. No need to
>> configure ad
>> min user.
>> 2011-02-11 11:56:05,112 [btpool0-6] INFO
>> com.opensymphony.xwork2.validator.Acti
>> onValidatorManagerFactory  - Detected AnnotationActionValidatorManager,
>> initiali
>> zing it...
>>
>>
>> On 11:55:52 archiva runs fine
>> PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
>> 6765 root      16   0  798m 326m  11m S  0.0  8.0   0:28.37 java
>>
>> On 11:58:52 it runs with full cpu usage
>>  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
>>
>> 6765 root      16   0  800m 346m  11m S 91.5  8.5   3:13.04 java
>>
>> After 12:01:52 it runs with 100% cpu usage. After restart it's all fine.
>>  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
>>
>> 6765 root      16   0  800m 353m  11m S 99.5  8.6   6:12.21 java
> 
> Very unusual. Can you confirm how many users are using it? How many requests are in the
request log in a 1 minute period around these times?
> 
> Also, can you try to get the thread dump as I indicated earlier? Are you using the Jetty
standalone, or running in Tomcat, etc.? (in which case, try kill -3 $PID instead)
> 
> Thanks,
> Brett
> 
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
> 
> 
> 
> 

-- 
Benjamin Knoth
Max Planck Digital Library (MPDL)
Systemadministration
Amalienstrasse 33
80799 Munich, Germany
http://www.mpdl.mpg.de

Mail: knoth@mpdl.mpg.de
Phone:  +49 89 38602 202
Fax:    +49-89-38602-280

Mime
View raw message