archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Brown" <charles.br...@sensis.com>
Subject error uploading artifact with really long ID's
Date Tue, 08 Feb 2011 16:25:41 GMT
I'm having a problem uploading one artifact of my build into Archiva 
1.3.1.  I've checked all the settings, and am confident this is not a 
permissions, settings.xml or pom.xml issue.  I suspect it's an issue 
with the groupID/artifactId, which are really long - 98 and 79 chars 
respectively.

The log shows a PUT of the artifact jar, which gets a response of 401, 
then 500.

Afterward, the archiva repository folder contains the jar, and it's the 
right size. It even cksum's.

The URL of the put is 319 characters long.

I suspect that once the jar has been copied into place, archiva is 
trying to update its database, but that the artifact name exceeds the 
database schema?

Is there a length limitation on the ID's?
-
This message is intended only for the addressee and may contain information that is company
confidential or privileged.  Any technical data in this message may be exported only in accordance
with the U.S. International Traffic in Arms Regulations (22 CFR Parts 120-130) or the Export
Administration Regulations (15 CFR Parts 730-774). Unauthorized use is strictly prohibited
and may be unlawful. If you are not the intended recipient, or the person responsible for
delivering to the intended recipient, you should not read, copy, disclose or otherwise use
this message. If you have received this email in error, please delete it, and advise the sender
immediately. 
-                                                                                        
                                                                                         
                                                                    

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message