archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brosius <dbros...@baybroadband.net>
Subject Re: Proxy problems with non .jar files
Date Wed, 03 Nov 2010 23:45:16 GMT
On 11/03/2010 11:17 AM, Wendy Smoak wrote:
> Is it not working for you locally either?
>

This is what i did,

1) Downloaded archiva 1.3.1 standalone, and unzipped it into two 
directories called local and remote.

2) Edited the jetty.xml file of the remote directory install to use port 
9090

3) Started both archivas

4) On archiva in remote dir (9090) added a remote repository thru the 
gui that had this information:

     Identifier: proxy
     Name: Proxy of Local
     URL: http://localhost:8080/archiva/repository/internal/
     UserName: as defined
     Password: as defined
     Timeout in Seconds: 60
     Type: Maven 2.x repository

5) On archiva in remote dir (9090) added a proxy connector thru the gui 
that had this information:

     Network Proxy: (direct connection)
     Managed Repository: internal
     Remote Repository: proxy
     (all other settings defaulted)

6) On archiva in local dir (8080) uploaded an artifact thru the gui that 
had this information:

     Group Id: com.mebigfatguy
     Artifact Id: fb-contrib
     Version: 4.6.0
     Packaging: jar
     Classifier: (blank)
     Generate Maven 2 POM: checked
     Artifact file: fb-contrib.jar
     Repository Id: internal

     and submitted it.

7) Next brought up firefox and entered url for the archiva in the remote 
dir (9090)

     
http://localhost:9090/archiva/repository/internal/com/mebigfatguy/fb-contrib/4.6.0/fb-contrib-4.6.0.xml

<http://localhost:9090/archiva/repository/internal/com/mebigfatguy/fb-contrib/4.6.0/fb-contrib-4.6.0.xml>

     and file is successfully downloaded

8) On archiva in local dir (8080) uploaded an artifact thru the gui that 
had this information:

     Group Id: com.mebigfatguy
     Artifact Id: build
     Version: 4.6.0
     Packaging: xml
     Classifier: (blank)
     Generate Maven 2 POM: checked
     Artifact file: build.xml
     Repository Id: internal

     and submitted it.

9) Next brought up firefox and entered url for the archiva in the 
*local* dir (8080)

     
http://localhost:8080/archiva/repository/internal/com/mebigfatguy/build/4.6.0/build-4.6.0.xml

<http://localhost:9090/archiva/repository/internal/com/mebigfatguy/fb-contrib/4.6.0/fb-contrib-4.6.0.xml>

     and the file is successfully downloaded

10) Next brought up firefox and entered url for the archiva in the 
*remote* dir (9090)

     
http://localhost:9090/archiva/repository/internal/com/mebigfatguy/build/4.6.0/build-4.6.0.xml

<http://localhost:9090/archiva/repository/internal/com/mebigfatguy/fb-contrib/4.6.0/fb-contrib-4.6.0.xml>

     Artifact is *not downloaded *and get this error page


         HTTP ERROR 404

     Problem accessing 
/archiva/repository/internal/com/mebigfatguy/build/4.6.0/build-4.6.0.xml. Reason:

     	Resource does not exist

------------------------------------------------------------------------
/Powered by Jetty:///





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message