archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fnord <li...@libertylost.org>
Subject Re: Publishing just a pom file?
Date Thu, 18 Nov 2010 20:21:26 GMT


Thanks for the advice, but it's still a no-go so far.

I'm setting:

Group Id: jboss
Artifact Id: jboss-compile-all
Version: 4.3.0_CP06
Packaging: pom
Classifier: blank
Generate Maven 2 POM: Unchecked
Artifact File: the .pom file I'm trying to publish
POM File: I've tried both including and not including the aforementioned
.pom file
Repository Id: internal

If I submit the form, I get "Please add a file to upload." I've verified
that the target.pom file has content, etc. I'm stumped.


Wendy Smoak-3 wrote:
> 
> On Thu, Nov 18, 2010 at 11:42 AM, fnord <lists@libertylost.org> wrote:
> 
>> The Archiva GUI won't let me publish a pom file, however. I set the
>> GroupID,
>> Artifact ID, version, type, etc. But when I choose the pom file to
>> publish
>> and hit Submit, all I get back is "Please add a file to upload."
>>
>> It won't let me select a .pom file to publish.
> 
> I can't quite tell how you're filling out the form from this info.
> 
> It's not terribly intuitive, but try choosing the .pom file for *both*
> the artifact file and the pom file.  It will upload the file twice,
> but I think the result will be what you're after.
> 
> If not, list the exact steps you're taking so I can try to reproduce
> it (because I have uploaded pom-only artifacts before.)
> 
> -- 
> Wendy
> 
> 

-- 
View this message in context: http://old.nabble.com/Publishing-just-a-pom-file--tp30249665p30250757.html
Sent from the archiva-users mailing list archive at Nabble.com.


Mime
View raw message