archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Antwort: Re: Authorization Denied (return code 401) at mvn:deploy after migration from 1.1.3 to 1.3.1
Date Thu, 12 Aug 2010 05:47:26 GMT

On 11/08/2010, at 9:13 PM, torsten.reinhard@gi-de.com wrote:

> Hi, 
> 
> yes the user have permission to the release repository, because he´s 
> Global Repository Manager as well as Global Repository Observer.
> The user mentioned in archiva.log (having no permission) is the user doing 
> the upload - it´s me and my own IP adress:-)

I meant, are you sure that Maven is sending the write username and password?

> In the "User Management" view some users are not checked (überprüft) and 
> some are locked (gesperrt) - why this?

You mean not checked - as in not "validated"?

Users that are locked will certainly fail to deploy.

Maybe the password has expired? There are more permanent solutions we can suggest if this
is the problem, but in the mean time you can try updating the account & password as an
admin to ensure it is not locked.

> Is there an SQL to check the database? Maybe something went wrong in the 
> migration phase?

You can manipulate the database, but there's nothing to "auto check" it - you'll see anything
either via the UI or an exception in the archiva logs if there's something unexpected.

I'd look into the user being locked, or the password not being right. If you can log in to
the UI as the user it should be fine to deploy.

- Brett

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





Mime
View raw message