archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Dehon <odn...@gmail.com>
Subject Re: `mvn deploy' failed
Date Thu, 08 Jul 2010 03:46:47 GMT
I am getting these kinds of metadata corruption all the time.

It seems to be linked to concurrent writes by mvn deploy (from
Continuum) and the Archiva "consumers" to fix the metadata. Notably,
after a release, the first snapshot build seems to get this "corrupted
metadata" error a lot, which I would link to the Archiva consumer that
deletes snapshots of released versions.

Another investigative track I am trying to follow is the potential
discrepancy between the metadata model used by maven 2.2.1 (and its
associated deploy plugin) and the one used by Archiva 1.2.x.

If anyone has any hints/pointers/advice, I'd be glad to read them.

Thanks in advance, -Olivier

On Thu, 2010-07-08 at 09:48 +0800, Deng Ching wrote:
> Can you check if the metadata file is correct? It looks like there are some
> escape characters that got in the metadata file..
> 
> On Wed, Jul 7, 2010 at 11:30 PM, Lenik <lenik@bodz.net> wrote:
> 
> > The output:
> >
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Building SECCA :: SEMS :: Parent
> > [INFO]    task-segment: [deploy]
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] [site:attach-descriptor {execution: default-attach-descriptor}]
> > [INFO] [install:install {execution: default-install}]
> > [INFO] Installing /home/appserv/build/parent/pom.xml to
> > /home/appserv/.m2/repository/com/seccaproject/sems/parent/1-SNAPSHOT/parent-1-SNAPSHOT.pom
> > [INFO] [deploy:deploy {execution: default-deploy}]
> > [INFO] Retrieving previous build number from seccasnapshots
> > [INFO] repository metadata for: 'snapshot
> > com.seccaproject.sems:parent:1-SNAPSHOT' could not be found on repository:
> > seccasnapshots, so will be created
> > Uploading:
> > http://m2.secca-project.com/snapshots/com/seccaproject/sems/parent/1-SNAPSHOT/parent-1-20100707.152611-1.pom
> > 583b uploaded  (parent-1-20100707.152611-1.pom)
> > [INFO] Retrieving previous metadata from seccasnapshots
> > [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local =
> > 'ca2ed90f79e38f171313fe040d7275d48c206350'; remote =
> > '39b09dae90456d0a47c1cc626d8b582235631de6' - RETRYING
> > [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local =
> > 'ca2ed90f79e38f171313fe040d7275d48c206350'; remote =
> > '39b09dae90456d0a47c1cc626d8b582235631de6' - IGNORING
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] BUILD ERROR
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Error installing artifact's metadata: Error installing metadata:
> > Error updating group repository metadata
> >
> > in epilog non whitespace content is not allowed but got t (position:
> > END_TAG seen ...</metadata>\nt... @9:2)
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] For more information, run Maven with the -e switch
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time: 9 seconds
> > [INFO] Finished at: Wed Jul 07 23:26:11 CST 2010
> > [INFO] Final Memory: 9M/17M
> > [INFO]
> > ------------------------------------------------------------------------
> >
> >
> >
> >
> > I have no idea what to do next.
> >
> > Thanks,
> > Lenik
> >



Mime
View raw message