archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Engebakken Geir <geir.engebak...@edb.com>
Subject RE: Unable to find project model for
Date Wed, 03 Mar 2010 09:33:39 GMT
Well in the repositories menu it looks ok :

Identifier  	 internal
Name  	 Archiva Managed Internal Repository
Directory 	/var/archiva/data/repositories/internal
WebDAV URL 	http://svn.edb.com/archiva/repository/internal/

Identifier  	 snapshots
Name 	Archiva Managed Snapshot Repository
Directory 	/var/archiva/data/repositories/snapshots
WebDAV URL 	http://svn.edb.com/archiva/repository/snapshots/

As to the health report, we are running archiva 1.1.1 so I don't think there are any health
reports available?


Geir
-----Original Message-----
From: odeaching@gmail.com [mailto:odeaching@gmail.com] On Behalf Of Deng Ching
Sent: 3. mars 2010 06:23
To: users@archiva.apache.org
Subject: Re: Unable to find project model for

Hi,

Were you able to check if the paths to the snapshots and internal
repositories are configured correctly? Can you also take a look at the
repository health report? The error should also show up there I think.

The problem you encountered looks a bit similar  to
http://jira.codehaus.org/browse/MRM-1278 , although in your case it seems
it's not displaying the artifact info page at all..

Thanks,
Deng

On Tue, Mar 2, 2010 at 10:04 PM, Engebakken Geir <geir.engebakken@edb.com>wrote:

> Hi all,
>
>
>
> We now have got an error  Unable to find project model for [path to POM
> artifact]
>
> I have checked the repository and the pom file mentioned is there.
>
> I have tried to touch the files in repository, and reindexed the
> repository, but it it doesn't help. Also tried the "update database now".
>
> Suddenly I noticed an error in the archiva.log which has a reference to the
> snapshots repository, but we talk about the same missing pom as in the
> internal repository. Anyone knows what happens here :
>
> ______________________________________________________________
> 2010-03-02 14:41:41,038 [btpool0-0] WARN
>  org.apache.maven.archiva.consumers.database.ProjectModelToDatabaseConsumer
>  -
> Unable to read project model
> /var/archiva/data/repositories/snapshots/com/edb/finance/customer/scs/customer/admin/edb-cu
> stomer-admin-business/1.8.1/edb-customer-admin-business-1.8.1.pom : file
> does not exist: /var/archiva/data/repositories/
>
> snapshots/com/edb/finance/customer/scs/customer/admin/edb-customer-admin-business/1.8.1/edb-customer-admin-business-1.8.
> 1.pom
> org.apache.maven.archiva.repository.project.ProjectModelException: file
> does not exist: /var/archiva/data/repositories/s
>
> napshots/com/edb/finance/customer/scs/customer/admin/edb-customer-admin-business/1.8.1/edb-customer-admin-business-1.8.1
> .pom
>        at
> org.apache.maven.archiva.repository.project.readers.ProjectModel400Reader.read(ProjectModel400Reader.java:112
>
>
>
>
>

Mime
View raw message