archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thorsten.scherler....@juntadeandalucia.es>
Subject Re: Uploading artifact with pom fails
Date Wed, 23 Dec 2009 12:17:14 GMT
On Wed, 2009-12-23 at 12:23 +0100, Thorsten Scherler wrote:
> Hi list,
> 
> I am facing a weird problem uploading artifacts with the web interface.
> As soon as I upload as well the pom the jars are not going to be
> uploaded. I attached the Post dump that I am using where I dropped the
> binary part of the jar in this mail.
> 
> As soon I now review 
> http://archiva.sadesi.es/browse/org.apache.droids/droids-core/0.1-incubating-SNAPSHOT
> 
> I get the orange box but only with the link to the jar, where the size
> is "00" and clicking on it results in:
> HTTP 404 of the underlying Apache Tomcat/5.5.28.
> 
> Is this a general bug or a misconfiguration of our rep?
> 
> O a side note I can publish our projects to the rep via "mvn deploy" and
> they show then well in the web. I will now try deploy:deploy-file and
> see what that gives.
> 

I tried with the deploy:deploy-file and got:
thorsten@asf:~/src/apache/droids/trunk/droids-solr$ mvn
deploy:deploy-file -Durl=http://archiva.sadesi.es/repository/central \
>                        -DrepositoryId=snapshots-SADESI \
>
-Dfile=target/droids-solr-0.1-incubating-SNAPSHOT.jar \
>                        -DpomFile=pom.xml \
>                        -DgroupId=org.apache.droids \
>                        -DartifactId=droids-solr \
>                        -Dversion=0.1-incubating-SNAPSHOT \
>                        -Dpackaging=jar
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'deploy'.
[INFO]
------------------------------------------------------------------------
[INFO] Building Droids Solr
[INFO]    task-segment: [deploy:deploy-file] (aggregator-style)
[INFO]
------------------------------------------------------------------------
[INFO] [deploy:deploy-file {execution: default-cli}]
[INFO] Retrieving previous build number from snapshots-SADESI
[INFO] repository metadata for: 'snapshot
org.apache.droids:droids-solr:0.1-incubating-SNAPSHOT' could not be
found on repository: snapshots-SADESI, so will be created
Uploading:
http://archiva.sadesi.es/repository/central/org/apache/droids/droids-solr/0.1-incubating-SNAPSHOT/droids-solr-0.1-incubating-20091223.114638-1.jar
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error deploying artifact: Failed to transfer file:
http://archiva.sadesi.es/repository/central/org/apache/droids/droids-solr/0.1-incubating-SNAPSHOT/droids-solr-0.1-incubating-20091223.114638-1.jar.
Return code is: 405

[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 4 seconds
[INFO] Finished at: Wed Dec 23 12:46:40 CET 2009
[INFO] Final Memory: 10M/79M


I am not sure what the actual problem is, somebody has an idea?

salu2
-- 
Thorsten Scherler <thorsten.at.apache.org>
Open Source Java <consulting, training and solutions>

Sociedad Andaluza para el Desarrollo de la Sociedad 
de la InformaciĆ³n, S.A.U. (SADESI)





Mime
View raw message