archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ulrich Metzger <ulr...@muehlgasse.de>
Subject Re: Archava behind mod_proxy
Date Fri, 21 Aug 2009 10:02:43 GMT
I have not tried mod_proxy but
would it be a solution to use tomcat as container with  mod_jk instead of
mod_proxy?

Here is my configuration:


#
JkWorkersFile /srv/www/tomcat/conf/workers.properties
JkLogFile     /var/log/apache2/mod_jk.log
JkMount /archiva/* ajp13

  # The following line prohibits users from directly accessing WEB-INF
  <Location "/archiva/WEB-INF/">
    AllowOverride None
    deny from all
  </Location>

otherwise  you could also use port forwarding on your external firewall


Uli

2009/8/20 Leon Kofman <leon.kofman@gmail.com>

> I am having issues with setting up Archiva behind mod_proxy.
>
>
>
> I have a very basic Archiva configuration using jetty with base URL of
> http://myserver.com/archiva
>
>
>
> Here is my Apache virtual host config
>
>
>
> <VirtualHost xxx.xxx.xx.xxx:80>
>
>   ServerName archiva.zic.pri
>
>   ServerAlias archiva
>
>
>
>   ProxyRequests     Off
>
>   ProxyPreserveHost On
>
>
>
>   <Proxy *>
>
>      Order deny,allow
>
>      Allow from all
>
>   </Proxy>
>
>
>
>
>
>   ProxyPass         /  http://localhost:8081/archiva/
>
>   ProxyPreserveHost On
>
>   ProxyPassReverse  /  http://localhost:8081/archiva/
>
>
>
>   <Location />
>
>       Order allow,deny
>
>       Allow from all
>
>   </Location>
>
>
>
> </VirtualHost>
>
>
>
>
>
> What happens, is I get a “*There is no Action mapped for action name index.
> - [unknown location]”  error.*
>
> * *
>
> *Also I get this in the archiva log:*
>
> *127.0.0.1 -  -  [20/Aug/2009:19:11:47 +0000] "GET
> /archiva/archiva/css/redback/table.css HTTP/1.1" 404 1423 "
> http://archiva.zic.pri/archiva/index.action" "Mozilla/4.0 (compatible;
> MSIE
> 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR
> 3.0.04506.30; .NET CLR 3.0.04506.648; InfoPath.1; MS-RTC LM 8)"*
>
>
>
> It like it’s not mapping reverse url properly.
>
>
>
> Did anyone set this up behind mod_proxy?  I appreciate any help!
>
>
>
>
>
> *Leon Kofman*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message