archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deng Ching <och...@apache.org>
Subject Re: Archiva 1.2.1 - repos won't get index
Date Thu, 04 Jun 2009 00:50:20 GMT
Hi Marc,

Did you touch the  contents of the repository? The last modified date of the
artifacts need to be more recent than the last run of the repository scan.
You can execute *find [REPOSITORY_DIRECTORY_NAME] | xargs touch *at the base
dir where your repo is located.

Thanks,
Deng

On Wed, Jun 3, 2009 at 11:54 PM, Marc Lustig <ml@marclustig.com> wrote:

>
> I forgot to add an excerpt from the log:
>
> 2009-06-03 17:42:11,554 [pool-2-thread-1] INFO
>
> org.apache.maven.archiva.scheduled.executors.ArchivaRepositoryScanningTaskExecutor
> - Finished repository task:
> .\ Scan of internal \.__________________________________________
>  Repository Dir    : /opt/managed_repos/internal
>  Repository Name   : ....
>  Repository Layout : default
>  Known Consumers   : (7 configured)
>                      auto-rename
>                      metadata-updater
>                      repository-purge
>                      auto-remove
>                      update-db-artifact
>                      create-missing-checksums
>                      index-content
>  Invalid Consumers : <none>
>  Duration          : 1 Minute 13 Seconds 689 Milliseconds
>  When Gathered     : 6/3/09 5:42 PM
>  Total File Count  : 107263
>  Avg Time Per File :
> ______________________________________________________________
> 2009-06-03 17:42:55,317 [pool-1-thread-1] INFO
>
> org.apache.maven.archiva.scheduled.executors.ArchivaDatabaseUpdateTaskExecutor
> - Executing task from queue with job name: database-job:user-requested
> 2009-06-03 17:42:55,319 [pool-1-thread-1] INFO
>
> org.apache.maven.archiva.scheduled.executors.ArchivaDatabaseUpdateTaskExecutor
> - Task: Updating unprocessed artifacts
> 2009-06-03 17:42:55,318 [http-8080-6] INFO
> org.apache.maven.archiva.web.action.admin.SchedulerAction  -
> [ActionMessage]
> Your request to update the database has been queued.
> 2009-06-03 17:42:55,591 [pool-1-thread-1] INFO
>
> org.apache.maven.archiva.scheduled.executors.ArchivaDatabaseUpdateTaskExecutor
> - Task: Updating processed artifacts
> 2009-06-03 17:44:20,355 [pool-1-thread-1] INFO
>
> org.apache.maven.archiva.scheduled.executors.ArchivaDatabaseUpdateTaskExecutor
> - Finished database task in 85035ms.
>
>
>
> Marc Lustig wrote:
> >
> > We upgraded our test-server to release 1.2.1, removed .index and .indexer
> > from all the repos, ran the Scan for the repos and then the Update
> > Database.
> >
> > As a result, before the upgrade we had 500 MB inside in all of the .index
> > directories.
> > After the upgrade and the repo-scan,  the total size is less than 1 MB.
> > Apparently the repo indexing-process does not work anymore. The
> > Search-function does not give any results.
> >
> > Any idea how to make the repos to get indexed again?
> >
>
> --
> View this message in context:
> http://www.nabble.com/Archiva-1.2.1---repos-won%27t-get-index-tp23854158p23854203.html
> Sent from the archiva-users mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message