archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davis Ford <davisf...@zenoconsulting.biz>
Subject can't resolve deployed snapshot
Date Mon, 18 May 2009 15:29:50 GMT
Hi, I've configured our builds to deploy snapshots to our archiva snapshot repo.

settings.xml -->

<settings>
	<mirrors>
		<mirror>
			<id>archiva.internal</id>
			<url>http://galileo:8080/archiva/repository/internal
			</url>
			<mirrorOf>*</mirrorOf>
		</mirror>
		<mirror>
			<id>archiva.snapshots</id>
			<url>http://galileo:8080/archiva/repository/snapshots
			</url>
			<mirrorOf>*</mirrorOf>
		</mirror>
	</mirrors>
	<servers>
		<server>
			<id>archiva.internal</id>
			<username>admin</username>
			<password>*******</password>
		</server>
		<server>
			<id>archiva.snapshots</id>
			<username>admin</username>
			<password>*******</password>
		</server>
	</servers>
</settings>

This is a multi-module project...parent pom.xml -->

<distributionManagement>
		<repository>
			<id>archiva.internal</id>
			<name>Internal Release Repository</name>
			<url>dav:http://galileo:8080/archiva/repository/internal/</url>
		</repository>
		<snapshotRepository>
			<id>archiva.snapshots</id>
			<name>Internal Snapshot Repository</name>
			<url>dav:http://galileo:8080/archiva/repository/snapshots/</url>
		</snapshotRepository>
</distributionManagement>

I can successfully deploy a snapshot to the repo, but I can't pull the
dependency down on another machine.  For example, if I deploy a
1.0-SNAPSHOT, I can navigate and find it in the snapshots repo in
archiva.

But, if I place a dependency on it:

	<dependencies>
		<dependency>
			<groupId>${project.groupId}</groupId>
			<artifactId>sl-ear</artifactId>
			<version>1.0-SNAPSHOT</version>
			<type>ear</type>
		</dependency>
	</dependencies>

[INFO] ------------------------------------------------------------------------
Downloading: http://galileo:8080/archiva/repository/snapshots/com/example/sl-ear/1.0-SNAPSHOT/sl-ear-1.0-SNAPSHOT.pom
Downloading: http://galileo:8080/archiva/repository/snapshots/com/example/sl-ear/1.0-SNAPSHOT/sl-ear-1.0-SNAPSHOT.ear
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

If I navigate to
http://galileo:8080/archiva/repository/snapshots/com/example/sl-ear/1.0-SNAPSHOT/

I see all the snapshots with timestamps.  Why can't maven resolve them?

TIA

-- 
Zeno Consulting, Inc.
home: http://www.zenoconsulting.biz
blog: http://zenoconsulting.wikidot.com
p: 248.894.4922
f: 313.884.2977

Mime
View raw message