archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deng Ching <odeach...@gmail.com>
Subject Re: Archiva 1.2 and xml webservices
Date Thu, 02 Apr 2009 15:39:11 GMT
Thanks! :)

-deng

On 4/2/09, Abel Muiño <amuino@gmail.com> wrote:
>
> Done, http://jira.codehaus.org/browse/MRM-1167
>
> I've attached the full project in case my tweaks to the client pom are
> causing the issue.
>
>
> Maria Odea Ching-5 wrote:
>>
>> Hmm, I don't think it is.. The indexing and search still happens at the
>> server, so it shouldn't matter if the indexer was excluded in the client..
>> Could you file a jira for this please? I'll take a look at it and see if I
>> can reproduce your problem.
>>
>> Thanks,
>> Deng
>>
>> On Tue, Mar 31, 2009 at 5:18 PM, Abel Muiño <amuino@gmail.com> wrote:
>>
>>>
>>> Hi Maria,
>>>
>>> Yes, I used the web interface and got some results.
>>>
>>> I've forgot to mention one tweak I did to the example pom, which is
>>> explicitly excluding the archiva-indexer from archiva-xmlrpc-api, since
>>> it
>>> brought in a few dependencies (3 maven artifacts with version suffix
>>> -SONATYPE-653485) which could not be resolved (and I didn't plan to
>>> actually
>>> index anything...).
>>>
>>> The relevant pom snippet is:
>>>    <dependency>
>>>      <groupId>org.apache.archiva</groupId>
>>>      <artifactId>archiva-xmlrpc-api</artifactId>
>>>      <version>1.2</version>
>>>      <exclusions>
>>>        <exclusion>
>>>                <groupId>org.apache.archiva</groupId>
>>>                <artifactId>archiva-indexer</artifactId>
>>>        </exclusion>
>>>      </exclusions>
>>>    </dependency>
>>>
>>> Could that be the reason I am not seeing results?
>>>
>>>
>>> Maria Odea Ching-5 wrote:
>>> >
>>> > Hi Abel,
>>> >
>>> > I don't think the logs have anything to do with it.. the logs come
>>> after
>>> > the
>>> > search is performed (it's cleaning up the context of the search).
>>> > Anyway, did you try searching the same query string from the web UI
>>> also?
>>> > Were you able to get any results or none as well?
>>> >
>>> > Thanks,
>>> > Deng
>>> >
>>> > On Tue, Mar 31, 2009 at 12:08 AM, Abel Muiño <amuino@gmail.com> wrote:
>>> >
>>> >>
>>> >> I'm trying to query an Archiva repository using the webservices API
in
>>> >> 1.2
>>> >> (http://archiva.apache.org/docs/1.2/adminguide/web-services.html). The
>>> >> repository has several artifacts and I can see results in the web
>>> >> interface.
>>> >>
>>> >> My code (based on archiva-xmlrpc-client) goes like this:
>>> >>
>>> >> SearchService searchService = binder.bind( SearchService.class, new
>>> >> URL("http://localhost:8082/archiva/xmlrpc" ),
>>> >>                new AuthenticationInfo( "admin", "admin123" ) );
>>> >> List<Artifact> artifacts = searchService.quickSearch( "org" );
>>> >>
>>> >> System.out.println( "\n************ Search Results for 'org'
>>> >> *************"
>>> >> );
>>> >> for( Artifact artifact : artifacts )
>>> >> {
>>> >>    System.out.println( "Artifact: " + artifact.getGroupId() + ":" +
>>> >> artifact.getArtifactId() +
>>> >>                        ":" + artifact.getVersion() );
>>> >> }
>>> >>
>>> >>
>>> >> ... but I'm getting zero results. After setting log4j to debug level
>>> for
>>> >> org.apache.archiva, I can see these two lines:
>>> >>
>>> >> 2009-03-30 18:06:41,552 [btpool0-4] DEBUG
>>> >> org.apache.archiva.indexer.search.NexusRepositorySearch  - Indexing
>>> >> context
>>> >> 'internal' removed from search.
>>> >> 2009-03-30 18:06:41,562 [btpool0-4] DEBUG
>>> >> org.apache.archiva.indexer.search.NexusRepositorySearch  - Indexing
>>> >> context
>>> >> 'snapshots' removed from search.
>>> >>
>>> >> Why are those repositories being removed from search and how can I
>>> search
>>> >> them?
>>> >>
>>> >> Thanks!
>>> >> --
>>> >> Abel Muiño.
>>> >>
>>> >> -----
>>> >> http://www.linkedin.com/in/amuino Abel Mui&ntilde;o Vizcaino  -
>>> >> http://ramblingabout.wordpress.com http://ramblingabout.wordpress.com
>>> >> --
>>> >> View this message in context:
>>> >>
>>> http://www.nabble.com/Archiva-1.2-and-xml-webservices-tp22786671p22786671.html
>>> >> Sent from the archiva-users mailing list archive at Nabble.com.
>>> >>
>>> >>
>>> >
>>> >
>>>
>>>
>>> -----
>>> http://www.linkedin.com/in/amuino Abel Mui&ntilde;o Vizcaino  -
>>> http://ramblingabout.wordpress.com http://ramblingabout.wordpress.com
>>> --
>>> View this message in context:
>>> http://www.nabble.com/Archiva-1.2-and-xml-webservices-tp22786671p22801304.html
>>> Sent from the archiva-users mailing list archive at Nabble.com.
>>>
>>>
>>
>>
>
>
> -----
> http://www.linkedin.com/in/amuino Abel Mui&ntilde;o Vizcaino  -
> http://ramblingabout.wordpress.com http://ramblingabout.wordpress.com
> --
> View this message in context:
> http://www.nabble.com/Archiva-1.2-and-xml-webservices-tp22786671p22845252.html
> Sent from the archiva-users mailing list archive at Nabble.com.
>
>

Mime
View raw message