archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Tran <dant...@gmail.com>
Subject Re: Nullpointer in VersionUtil when uploading
Date Thu, 12 Mar 2009 00:10:31 GMT
I see same error after upgrade from 1.1.3 to 1.2-M1, does any one get
this to work with a fresh 1.2-M1?

-D

On Tue, Nov 18, 2008 at 2:58 PM, Brett Porter <brett@apache.org> wrote:
> Was this working in 1.1.3?
>
> 1.2-M1 is still a pre-release and may have some issues.
>
> - Brett
>
> On 19/11/2008, at 3:52 AM, Raphael Parree wrote:
>
>> Hi,
>>
>> When deplying i'm getting the following exception:
>>
>> javax.servlet.ServletException: java.lang.NullPointerException
>>
>>  org.apache.struts2.dispatcher.Dispatcher.serviceAction(Dispatcher.java:515)
>>
>>  org.apache.struts2.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:419)
>>
>>  com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
>>
>>  com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
>>
>>  org.apache.struts2.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:99)
>>
>> *root cause*
>>
>> java.lang.NullPointerException
>>
>>  org.apache.maven.archiva.common.utils.VersionUtil.isVersion(VersionUtil.java:92)
>>
>>  org.apache.maven.archiva.web.action.UploadAction.validate(UploadAction.java:597)
>>
>>  com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor.doIntercept(DefaultWorkflowInterceptor.java:200)
>>
>>  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor.intercept(MethodFilterInterceptor.java:86)
>>
>>  com.opensymphony.xwork2.DefaultActionInvocation$2.doProfiling(DefaultActionInvocation.java:224)
>>
>>
>>
>> The information in the form is:
>> group id: eXist
>> Artefact id: exist-xmldb
>> Version: 1.3.0-SNAPSHOT
>> Packaging:jar
>> Generate Maven POM
>> file: exist.jar
>> Rep id: snapshots
>>
>> Strange thing is that when i use the same settings but a different jar
>> file
>> (exist-optional.jar-273 kb) it works, go back and try again the
>> exist.jar-3.175kb it does not work.  Looking at the source code seems to
>> show it has to do with the version string (
>>
>> http://svn.apache.org/viewvc/archiva/tags/archiva-1.2-M1/archiva-modules/archiva-web/archiva-webapp/src/main/java/org/apache/maven/archiva/web/action/UploadAction.java?view=markup)
>> but that does not seem to make sense....
>>
>>
>> I am using Apache Archiva 1.2-M1 (upgraded today from 1.1.3)
>>
>>
>> Any clues?
>> --
>> Raphael Parree
>
> --
> Brett Porter
> brett@apache.org
> http://blogs.exist.com/bporter/
>
>

Mime
View raw message