archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kraft, Mike" <Mike.Kr...@teradact.com>
Subject Https support
Date Tue, 23 Sep 2008 17:44:46 GMT
Hi,
 
I'm new to Archiva and this list, so please forgive me if this is a dumb question. I would
like to use our Archiva repositories via https. We are running Archiva 1.1.2 in Tomcat 6.
I have set up Tomcat properly for https, and I can successfully browse the Archiva web app
via https. However, all attempts to download from or deploy to the Archiva repositories via
https or dav:https fail (note that attempts using unencrypted http or dav:http succeed).
 
For example, when using dav:https and mvn deploy, I get this error on the command line:
[INFO] Error deploying artifact: Failed to create destination WebDAV collection (directory):
/archiva/repository/internal/com/teradact/testBuild/0.20.0
 
unable to find valid certification path to requested target
[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: Error deploying artifact: Failed to
create destination WebDAV collection (directory): /archiva/repository/internal/com/teradact/testBuild/0.20.0
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:583)
...
 
With just https:
[INFO] Error deploying artifact: Error transferring file (directory): /archiva/repository/internal/com/teradact/testBuild/0.20.0
 
unable to find valid certification path to requested target
[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: Error deploying artifact: Error transferring
file (directory): /archiva/repository/internal/com/teradact/testBuild/0.20.0
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:583)
...
 
Archiva's own logs show nothing for these events.
 
Have I missed something? Is there any way to set up Archiva and/or Maven so https will work?
 
Thanks in advance,
Mike
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message