archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Randy Kamradt" <Randy.Kamr...@jda.com>
Subject RE: Archiva/Tomcat config help
Date Mon, 29 Sep 2008 17:36:57 GMT
Adding files to the webapps/ROOT directory was probably not a good idea,
that's a special case directory intended for handling the '/' URL path.
See if you can restore the webapps/ROOT directory and restart tomcat.

-----Original Message-----
From: waaraa1331 [mailto:waaraa1331@yahoo.com] 
Sent: Monday, September 29, 2008 10:29 AM
To: users@archiva.apache.org
Subject: Re: Archiva/Tomcat config help


So far I have downloaded the webapp .WAR file.  I have setup
apache-tomcat and was able to get the default tomcat homepage.  I put
the war file in a folder named archiva which i made on the same level as
the tomcat conf directory.  Inside conf/Catalina/localhost i made the
archiva.xml file which looks like this 

<?xml version="1.0" encoding="UTF-8"?>
<Context path="/archiva"
          docBase="${catalina.home}/archiva/apache-archiva-1.1.1.war">

 <Resource name="jdbc/users" auth="Container"
type="javax.sql.DataSource"
           username="user"
           password="pass"
           driverClassName="com.mysql.jdbc.Driver"
           url="jdbc:mysql:///111.11.1.1/db;create=true" />

 <Resource name="jdbc/archiva" auth="Container"
type="javax.sql.DataSource"
           username="pass"
           password="pass"
           driverClassName="com.mysql.jdbc.Driver"
           url="jdbc:mysql:///111.11.1.1/db;create=true" />

 <Resource name="mail/Session" auth="Container"
            type="javax.mail.Session"
            mail.smtp.host="localhost"/>  </Context>

*address and DB names have been changed but the IP's work and the DBs
exist and the users exist*

I also downloaded derby-10.1.3.1.jar, activation-1.1.jar,
derbytools-10.1.3.1.jar and mail-1.4.jar and put those in the lib
folder.  
I also made webapps/ROOT/META-INF/context.xml file which is the same as
the file above.  I have been using the following two sites for most of
my config setup.
http://archiva.apache.org/docs/1.0.2/adminguide/webapp.html
http://cwiki.apache.org/confluence/display/ARCHIVA/Archiva+on+Tomcat

I have downloaded the mysql connector to the tomcat lib folder and tried
it in the webapps/ROOT/WEB-INF/lib folder as well and it nothing works.
If you have any other questions please let me know. Hope this helps.
--
View this message in context:
http://www.nabble.com/Archiva-Tomcat-config-help-tp19694123p19728198.htm
l
Sent from the archiva-users mailing list archive at Nabble.com.


Mime
View raw message