archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Tran" <dant...@gmail.com>
Subject Re: Debugging Archiva with Eclipse and Tomcat
Date Fri, 08 Aug 2008 16:38:53 GMT
I lies, spoke too fast.

both maven-meta-data.xml and its checksum files are not regenerated.

Wonder, if someone else can confirm this?

-D

On Fri, Aug 8, 2008 at 12:41 AM, Brett Porter <brett.porter@gmail.com> wrote:
> 2008/8/8 Dan Tran <dantran@gmail.com>:
>> Thanks Brett,
>>
>> I am able to use your instructions  together with eclipse plugin and
>> WTP  to load archiva with eclipse IDE and tomcat.
>>
>> BTW, why mail and derby jars are not part of the webapps?
>
> They usually are required by the servlet container's classloader, not
> the web application's classloader so that the container can construct
> the data sources. Actually, it's possible to deploy the WAR without
> using derby at all, in which case you'd provide a different JDBC
> driver in the servlet container.
>
> Cheers,
> Brett
>
>>
>>
>>
>> On Thu, Aug 7, 2008 at 8:35 PM, Brett Porter <brett.porter@gmail.com> wrote:
>>> Here is how I do it:
>>> http://cwiki.apache.org/confluence/display/ARCHIVA/Setting+up+Archiva+in+Eclipse+with+Q4E
>>> (Q4E is not a requirement if you want to set up the projects and WTP
>>> differently)
>>>
>>> I hope you'll join dev@archiva.apache.org to ask questions and let us
>>> know how it goes if you have some improvements to contribute :)
>>>
>>> Cheers,
>>> Brett
>>>
>>> 2008/8/8 Dan Tran <dantran@gmail.com>:
>>>> I would like to fire up Archiva webapp under Eclipse with Tomcat
>>>> container.  Is there any thing I need to do before and after fireup
>>>> tomcat?
>>>>
>>>> -D
>>>>
>>>
>>>
>>>
>>> --
>>> Brett Porter
>>> Blog: http://blogs.exist.com/bporter/
>>>
>>
>
>
>
> --
> Brett Porter
> Blog: http://blogs.exist.com/bporter/
>

Mime
View raw message