archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carr, Brian M" <brianmc...@austin.utexas.edu>
Subject Re: LDAP auth instructions/how to?
Date Tue, 05 Aug 2008 13:24:41 GMT
FYI, The redback-commons-ldap packaged with Archiva (and continuum) does not
support LDAPS. That tripped me up for a while, as the exception thrown is
³service not available².

--b


On 8/4/08 10:08 PM, "Maria Odea Ching" <oching@apache.org> wrote:

> Hi Chris,
> 
> You just need to put the LDAP config in your security.properties file, you
> no longer need to edit the application.xml as specified here:
> http://redback.codehaus.org/integration/ldap.html (just copy & paste the
> config specifed in the security.properties section)
> 
> And you might also need to add the LDAP specific configuration specified in
> the LDAP Settings section in this document:
> http://redback.codehaus.org/configuration.html
> 
> HTH,
> Deng
> 
> On Tue, Aug 5, 2008 at 8:16 AM, Chris Brentano <
> chris.brentano@jivesoftware.com> wrote:
> 
>> > Hi all,
>> >
>> > I'd like to configure Archiva to do LDAP authentication to Active
>> > Directory. It appears that Redback has LDAP support, and I've seen some
>> > various bits here and there about configuring the security.properties or
>> > application.xml file to utilize LDAP, but I can't find a concise guide. Can
>> > anyone provide some basic instructions and are there any gotchas I should
>> be
>> > aware of? Thanks!
>> >
>> > - Chris
>> >
> 


______________________________
Brian M. Carr
Identity and Access Management
ITS Applications
University of Texas at Austin
V: 512-232-6419
F: 512-471-5746
brianmcarr@austin.utexas.edu



Mime
View raw message