archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Johnson" <amarkjohn...@gmail.com>
Subject Re: Unable to Administer via Web
Date Wed, 16 Jul 2008 23:36:04 GMT
I have had this same problem, but not with the admin user, rather with other
new users I have created.  I think I have found the problem.  If a user only
has the role of "Repository Manager", then all that user can do is
browse/serarch. I have to assign the user to the "System Administrator" role
to get Repository Management rights, but I also get system admin rights.

Mark


> Thanks. If I come up with anything, I'll update the issue.

> Quoting Brett Porter <brett.porter@gmail.com>:

> I believe you are experiencing this issue:

> http://jira.codehaus.org/browse/MRM-728
>
> To date, I've had trouble reproducing this. We'd be glad for your
> additional information.

>
> Regards,
> Brett
>
> 2008/7/4  <twolff@bluestemsoftware.com>:
>> Hi,
>>
>> Installed version 1.0.2 on fedora core 7. I separated the

>> configuration from the
>> installation as indicated and performed a recursive chown of
>> /opt/apache-archiva-1.0.2 and /var/archiva to a non-root user.
>> Started archiva
>> as non-root user and saw no errors in archiva.log or wrapper log.

>>
>> Go to web console (from remote machine) and login as admin. The
>> search page is
>> displayed with no admin menus (see attached screenshot.)  Note that
>> if I enter
>> the wrong password I get a login error, so I know it is logging in

>> as 'admin'
>> correctly, but the displayed page acts as though I am not logged in.
>>
>> Tried running archiva as root - still no love. I can browse and search the
>> repositories and I am able to deploy to them (as user 'admin'), but I can't

>> administer them.  Any ideas?
>>
>>
>
>
>
> --
> Brett Porter
> Blog: http://blogs.exist.com/bporter/
>

>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message