archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: You shouldn't have to grant the System Administrator role... there is
Date Thu, 24 Jul 2008 16:29:40 GMT
If you grant the Repository Manager role, the user will be able to
deploy things to the repository, but no new menu options will appear.

What menu options are you trying to enable?

I don't think we have per-repository *admin* roles, only management
(which means changing  the contents of the repo, but not the
configuration.)

-- 
Wendy

On Thu, Jul 24, 2008 at 8:45 AM, Mark Johnson <amarkjohnson@gmail.com> wrote:
> I have the same problem on 1.1.  I have grated all combinations of roles,
> (Repo Manager to specific repos, Global Repo Manager, User Admin, etc).
> Unless I give the user "System Administrator" role, when that users logs in,
> they only things they see are [Search, Find Artifact, and Browse].  Has
> anyone else experienced this?  I cannot find a jira issue, but don't know
> well how to search Jira.
>
> Mark
>
>
> On Wed, 16 Jul 2008 8:16 PM, Wendy Smoak <"Wendy Smoak" <wsmoak@gmail.com>
> wrote:
>> You shouldn't have to grant the System Administrator role... there is
>> a Repository Manager role for each repo, as well as a global one. Are
>> you not seeing those when you edit a user?
>
> On Wed, Jul 16, 2008 at 4:36 PM, Mark Johnson <amarkjohnson@gmail.com>
> wrote:
>> I have had this same problem, but not with the admin user, rather with
> other
>> new users I have created. I think I have found the problem. If a user only
>> has the role of "Repository Manager", then all that user can do is
>> browse/serarch. I have to assign the user to the "System Administrator"
> role
>> to get Repository Management rights, but I also get system admin rights.
>

Mime
View raw message