archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: Unable to use stage-plugin with archiva as http source
Date Sat, 26 Jul 2008 05:22:09 GMT
great - feel free to file a bug in Archiva too - though it's not
incorrect, it'd be better without it and we can probably fix this more
easily than getting the updated version to the maven client.

2008/7/26 Dan Tran <dantran@gmail.com>:
> I look the html contains for repo1.apache.org/maven2 and the archiva
> at http://archiva.openqa.org/repository/releases/
>
> the repo1 shows
> <img src="/icons/folder.gif" alt="[DIR]"> <a href="abbot/">abbot/</a>
>    31-Oct-2005 23:09    -
>
> the archiva shows
>
> <li><a href="./org/">org/</li>
>
>
> So the problem  area seems to be at the extra "./" at archiva.
>
> will write up a test case for this.
>
> -D
>
> On Fri, Jul 25, 2008 at 10:01 PM, Dan Tran <dantran@gmail.com> wrote:
>> sure, i will look into it
>>
>> thanks
>>
>> -D
>>
>> On Fri, Jul 25, 2008 at 9:57 PM, Brett Porter <brett.porter@gmail.com> wrote:
>>> Yes, that'd be the place to look (it's just that it's on the end of
>>> the stage plugin where it is occurring :)
>>>
>>> 2008/7/26 Dan Tran <dantran@gmail.com>:
>>>> you mean http wagon?
>>>>
>>>> -D
>>>>
>>>> On Fri, Jul 25, 2008 at 9:45 PM, Brett Porter <brett.porter@gmail.com>
wrote:
>>>>> That would be an issue with the stage plugin I think - the HTML on
>>>>> Archiva looks fine to me.
>>>>>
>>>>> 2008/7/26 Dan Tran <dantran@gmail.com>:
>>>>>> From the other post, is it is same error for both 1.1( mine) and
1.0.2
>>>>>> (other user)  archiva.  When the stage plugin asks for a list
>>>>>> of files available at source repo ( ie the staging repo), it gets
a
>>>>>> list of one item ( a space )
>>>>>>
>>>>>> on windows, the error is access deny, and unix it complains about
cant
>>>>>> not create directory.
>>>>>>
>>>>>> -D
>>>>>>
>>>>>> On Fri, Jul 25, 2008 at 9:33 PM, Brett Porter <brett.porter@gmail.com>
wrote:
>>>>>>> The stage plugin doesn't support http targets, that's correct.
>>>>>>>
>>>>>>> There was previously some bugs in the HTML rendering, but they
should
>>>>>>> be fine under 1.1. Is that what you are seeing?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Brett
>>>>>>>
>>>>>>> 2008/7/26 Dan Tran <dantran@gmail.com>:
>>>>>>>> Dont think it is a bug, but worth to ask.
>>>>>>>>
>>>>>>>> see http://www.nabble.com/Re%3A-error-plugin-stage-to16634443.html
>>>>>>>>
>>>>>>>> I am using archiva 1.1 on linux
>>>>>>>>
>>>>>>>> -D
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Brett Porter
>>>>>>> Blog: http://blogs.exist.com/bporter/
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Brett Porter
>>>>> Blog: http://blogs.exist.com/bporter/
>>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Brett Porter
>>> Blog: http://blogs.exist.com/bporter/
>>>
>>
>



-- 
Brett Porter
Blog: http://blogs.exist.com/bporter/

Mime
View raw message