archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jaxzin <Brian.R.Jack...@espn3.com>
Subject Re: [MRM-730] not fixed? Can't search on class names?
Date Sat, 26 Jul 2008 03:18:49 GMT

I think I'm starting to understand. :-)  I pressed both the "Update
Consumers" and "Update Database Now" buttons and got the following in my
log:

2008-07-25 23:11:11,049 [pool-1-thread-1] INFO 
org.apache.maven.archiva.scheduled.executors.ArchivaDatabaseUpdateTaskExecutor 
- Executing task from queue with job name: database-job:user-requested
2008-07-25 23:11:11,049 [pool-1-thread-1] INFO 
org.apache.maven.archiva.scheduled.executors.ArchivaDatabaseUpdateTaskExecutor 
- Task: Updating unprocessed artifacts

I don't see anywhere to track progress, so I'll give it a couple of hours to
index and see if I have better search results.  Thanks for the fast
responses everyone!




Maria Odea Ching-5 wrote:
> 
> Sorry about the confusion over this, but the consumer for indexing the
> java
> classes/packages is the index-public-methods under db scanning.
> So you should also execute the database scanner to be able to search for
> it..
> 
> Thanks,
> Deng
> 
> On Sat, Jul 26, 2008 at 10:54 AM, jaxzin <Brian.R.Jackson@espn3.com>
> wrote:
> 
>>
>> BTW, I needed to delete the database to get the scanner to recreate the
>> .index folder.
>>
>>
>>
>> jaxzin wrote:
>> >
>> > I hate to be Debbie Downer but it ain't working. :-) I reindexed my
>> > snapshots repository and it's still not working.  For my class
>> > "disney.entrepot.util.HardDepot" I've tried the following searches all
>> > with no results:
>> >
>> > HardDepot
>> > HardDepot.class
>> > disney.entrepot.util.HardDepot
>> >
>> > Since I upgraded and took an exact copy of my archiva.xml, is it
>> possibly
>> > my artifacts and/or indexable-content settings aren't right for this to
>> > work?  Here's my listings off the repositoryScanning.action page:
>> >
>> > artifacts
>> > **/*.pom
>> > **/*.jar
>> > **/*.ear
>> > **/*.war
>> > **/*.car
>> > **/*.sar
>> > **/*.mar
>> > **/*.rar
>> > **/*.dtd
>> > **/*.tld
>> > **/*.tar.gz
>> > **/*.tar.bz2
>> > **/*.zip
>> >
>> > auto-remove
>> > **/*.bak
>> > **/*~
>> > **/*-
>> >
>> > ignored
>> > **/.htaccess
>> > **/KEYS
>> > **/*.rb
>> > **/*.sh
>> > **/.svn/**
>> > **/.DAV/**
>> >
>> > indexable-content
>> > **/*.txt
>> > **/*.TXT
>> > **/*.block
>> > **/*.config
>> > **/*.pom
>> > **/*.xml
>> > **/*.xsd
>> > **/*.dtd
>> > **/*.tld
>> > **/*.java
>> >
>> > Repository Scanning - Consumers of Known Content
>> >       Enabled?        ID      Description
>> >       enabled         auto-remove     Automatically Remove File from
>> Filesystem.
>> >       enabled         auto-rename     Automatically rename common
>> artifact mistakes.
>> >       enabled         create-missing-checksums        Create Missing
>> Checksums (.sha1 &
>> > .md5)
>> >       enabled         index-content   Text and XML file contents
>> indexing
>> >       enabled         metadata-updater        Update / Create
>> maven-metadata.xml files
>> >       enabled         repository-purge        Purge repository of old
>> snapshots
>> >       enabled         update-db-artifact      Update the Artifact in
>> the
>> Database
>> >       enabled         validate-checksums      Validate checksums
>> against
>> file.
>> >
>> >
>> > Repository Scanning - Consumers of Invalid Content
>> > There are no consumers of invalid content available.
>> >
>> >
>> >
>> >
>> >
>> >
>> > Brett Porter wrote:
>> >>
>> >> That should do it!
>> >>
>> >> 2008/7/26 jaxzin <Brian.R.Jackson@espn3.com>:
>> >>>
>> >>> Thanks Brett.  What exactly are the instructions?  Remove the .index
>> >>> directory and rescan?  Anything else?
>> >>>
>> >>>
>> >>>
>> >>> Brett Porter wrote:
>> >>>>
>> >>>> I believe that it's the index (stored in the .index directory of
the
>> >>>> repository) that needs to be recreated. Unfortunately there isn't
an
>> >>>> option to force this from the UI and it needs to be removed.
>> >>>>
>> >>>> We'll need to update the upgrade instructions for this.
>> >>>>
>> >>>> Cheers,
>> >>>> Brett
>> >>>>
>> >>>> 2008/7/26 jaxzin <Brian.R.Jackson@espn3.com>:
>> >>>>>
>> >>>>> I did upgrade from 1.0.2, but I also deleted the database and
had
>> >>>>> Archiva
>> >>>>> 1.1
>> >>>>> rebuild it.
>> >>>>>
>> >>>>>
>> >>>>> Maria Odea Ching-5 wrote:
>> >>>>>>
>> >>>>>> Hi,
>> >>>>>>
>> >>>>>> Did you just do an upgrade from an old Archiva version?
Or was it
>> a
>> >>>>>> fresh
>> >>>>>> install?
>> >>>>>>
>> >>>>>> Thanks,
>> >>>>>> Deng
>> >>>>>>
>> >>>>>> On Fri, Jul 25, 2008 at 12:22 PM, jaxzin
>> <Brian.R.Jackson@espn3.com
>> >
>> >>>>>> wrote:
>> >>>>>>
>> >>>>>>>
>> >>>>>>> I was excited to see MRM-730 was listed in the release
notes for
>> >>>>>>> Archiva
>> >>>>>>> 1.1
>> >>>>>>> but I'm testing it right now and I can't seem to find
any
>> artifacts
>> >>>>>>> by
>> >>>>>>> class
>> >>>>>>> name.  I've ensured that the artifact was indexed in
a repository
>> >>>>>>> search
>> >>>>>>> (I
>> >>>>>>> can browse to it) and I double-checked the name of one
of the
>> >>>>>>> classes
>> >>>>>>> (e.g.
>> >>>>>>> JMXPlugin) but I still get "No results found".  What
could I be
>> >>>>>>> missing?
>> >>>>>>> --
>> >>>>>>> View this message in context:
>> >>>>>>>
>> http://www.nabble.com/-MRM-730--not-fixed--Can%27t-search-on-class-names--tp18644961p18644961.html
>> >>>>>>> Sent from the archiva-users mailing list archive at
Nabble.com.
>> >>>>>>>
>> >>>>>>>
>> >>>>>>
>> >>>>>>
>> >>>>>
>> >>>>> --
>> >>>>> View this message in context:
>> >>>>>
>> http://www.nabble.com/-MRM-730--not-fixed--Can%27t-search-on-class-names--tp18644961p18653075.html
>> >>>>> Sent from the archiva-users mailing list archive at Nabble.com.
>> >>>>>
>> >>>>>
>> >>>>
>> >>>>
>> >>>>
>> >>>> --
>> >>>> Brett Porter
>> >>>> Blog: http://blogs.exist.com/bporter/
>> >>>>
>> >>>>
>> >>>
>> >>> --
>> >>> View this message in context:
>> >>>
>> http://www.nabble.com/-MRM-730--not-fixed--Can%27t-search-on-class-names--tp18644961p18662363.html
>> >>> Sent from the archiva-users mailing list archive at Nabble.com.
>> >>>
>> >>>
>> >>
>> >>
>> >>
>> >> --
>> >> Brett Porter
>> >> Blog: http://blogs.exist.com/bporter/
>> >>
>> >>
>> >
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/-MRM-730--not-fixed--Can%27t-search-on-class-names--tp18644961p18662566.html
>> Sent from the archiva-users mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/-MRM-730--not-fixed--Can%27t-search-on-class-names--tp18644961p18662698.html
Sent from the archiva-users mailing list archive at Nabble.com.


Mime
View raw message