archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse" <emmanuel.veni...@gmail.com>
Subject Re: SMTP Settings
Date Fri, 13 Jun 2008 15:48:57 GMT
:)
no problem

On Fri, Jun 13, 2008 at 5:33 PM, Andi Weibel <andi.weibel@gmail.com> wrote:

> Hi Emmanuel,
>
> I counter-checked everything again and realized - to my embarrassement -
> that the working continuum actually runs on a slightly different server...
>
> I also found that I can't connect to the SMTP-Server from the server that
> should host archiva using telnet. Thus, it seems that the problem has
> nothing to do with archiva and I will need to talk to our systems guys in
> order to open up port 25...
>
> Thanks for your help nevertheless!
> Andi
>
>
> On Fri, Jun 13, 2008 at 4:36 PM, Emmanuel Venisse <
> emmanuel.venisse@gmail.com> wrote:
>
> > hmm, Continuum and archiva use the same librairies to send mails.
> >
> > Do you have a specific security.properties where you redefined some mail
> > property?
> >
> > On Fri, Jun 13, 2008 at 4:29 PM, Andi Weibel <andi.weibel@gmail.com>
> > wrote:
> >
> > > Hi Emmanuel,
> > >
> > > Thanks for your help. Tomcat's stdout.log contains the entries below.
> > >
> > > ----------------------
> > >
> > > There was no such logger
> > >
> > >
> >
> 'org.codehaus.plexus.redback.xwork.filter.authentication.HttpAuthenticator:basic'
> > > 26453615.
> > > DEBUG: setDebug: JavaMail version 1.4ea
> > > DEBUG: getProvider() returning
> > > javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun
> > > Microsystems, Inc]
> > > DEBUG SMTP: useEhlo true, useAuth false
> > > DEBUG SMTP: trying to connect to host "smtp.mycompany.ch", port 25,
> > isSSL
> > > false
> > > There was no such logger
> > >
> > >
> >
> 'org.codehaus.plexus.redback.xwork.filter.authentication.HttpAuthenticator:basic'
> > > 13508999.
> > > DEBUG: setDebug: JavaMail version 1.4ea
> > > DEBUG: getProvider() returning
> > > javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun
> > > Microsystems, Inc]
> > > DEBUG SMTP: useEhlo true, useAuth false
> > > DEBUG SMTP: trying to connect to host "smtp.mycompany.ch", port 25,
> > isSSL
> > > false
> > > DEBUG: setDebug: JavaMail version 1.4ea
> > > DEBUG: getProvider() returning
> > > javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun
> > > Microsystems, Inc]
> > > DEBUG SMTP: useEhlo true, useAuth false
> > > DEBUG SMTP: trying to connect to host "smtp.mycompany.ch", port 25,
> > isSSL
> > > false
> > >
> > > ----------------------
> > >
> > > There is nothing more in the logs apart from that (in particular in
> > > archiva.log).
> > >
> > > Thanks,
> > > Andi
> > >
> > >
> > >
> > > On Fri, Jun 13, 2008 at 3:45 PM, Emmanuel Venisse <
> > > emmanuel.venisse@gmail.com> wrote:
> > >
> > > > Do you have more informations in your logs? the debug mode you
> > activated
> > > > should be verbose.
> > > >
> > > > Emmanuel
> > > >
> > > > On Fri, Jun 13, 2008 at 3:07 PM, Andreas Weibel <
> andi.weibel@gmail.com
> > >
> > > > wrote:
> > > >
> > > > > Hi all,
> > > > >
> > > > > I'm having a problem with the mail configuration of archiva
> > > (archiva1.0.2
> > > > > on
> > > > > a tomcat 6.0.16 with mail-1.4.jar). I'm constantly getting a
> > > > > could-not-connect exception. I counter-checked the settings several
> > > > times.
> > > > > And there shouldn't be a problem with a firewall - continuum runs
> on
> > > the
> > > > > same server with exactely the same settings.
> > > > >
> > > > > Any hints what might go wrong?
> > > > >
> > > > > Best,
> > > > > andreas
> > > > >
> > > > > ---- context.xml ------------------------
> > > > >
> > > > >  <Resource name="mail/Session" auth="Container"
> > > > >            type="javax.mail.Session"
> > > > >            mail.smtp.host="smtp.mycompany.ch"
> > > > >            mail.smtp.auth="false"
> > > > >            mail.smtp.debug="true" />
> > > > >
> > > > >
> > > > > ---- Failure Trace ---------------------
> > > > >
> > > > > 2008-06-13 14:42:43,120 [http-8080-1] ERROR
> > > > > org.codehaus.plexus.redback.xwork.mail.Mailer:default  - Unable to
> > send
> > > > > message, subject [Welcome to Maven Archiva]
> > > > > org.codehaus.plexus.mailsender.MailSenderException: Error while
> > sending
> > > > the
> > > > > message.
> > > > >    at
> > > > >
> > > > >
> > > >
> > >
> >
> org.codehaus.plexus.mailsender.javamail.AbstractJavamailMailSender.send(AbstractJavamailMailSender.java:224)
> > > > >    at
> > > > >
> > > >
> > >
> >
> org.codehaus.plexus.redback.xwork.mail.Mailer.sendMessage(Mailer.java:145)
> > > > >    at
> > > > >
> > > > >
> > > >
> > >
> >
> org.codehaus.plexus.redback.xwork.mail.Mailer.sendAccountValidationEmail(Mailer.java:70)
> > > > >    at
> > > > >
> > > > >
> > > >
> > >
> >
> org.codehaus.plexus.redback.xwork.action.RegisterAction.register(RegisterAction.java:166)
> > > > >    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > > > >    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> > > > >    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
> Source)
> > > > >    at java.lang.reflect.Method.invoke(Unknown Source)
> > > > >    at
> > > > >
> > > > >
> > > >
> > >
> >
> com.opensymphony.xwork.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:358)
> > > > >    [...]
> > > > > Caused by: javax.mail.MessagingException: Could not connect to SMTP
> > > host:
> > > > > smtp.mycompany.ch, port: 25;
> > > > >  nested exception is:
> > > > >    java.net.ConnectException: Connection refused: connect
> > > > >    at
> > > com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1282)
> > > > >    at
> > > > >
> > com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:370)
> > > > >    at javax.mail.Service.connect(Service.java:275)
> > > > >    at
> > > > >
> > > > >
> > > >
> > >
> >
> org.codehaus.plexus.mailsender.javamail.AbstractJavamailMailSender.send(AbstractJavamailMailSender.java:210)
> > > > >    ... 72 more
> > > > > Caused by: java.net.ConnectException: Connection refused: connect
> > > > >    at java.net.PlainSocketImpl.socketConnect(Native Method)
> > > > >    at java.net.PlainSocketImpl.doConnect(Unknown Source)
> > > > >    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
> > > > >    at java.net.PlainSocketImpl.connect(Unknown Source)
> > > > >    at java.net.SocksSocketImpl.connect(Unknown Source)
> > > > >    at java.net.Socket.connect(Unknown Source)
> > > > >    at java.net.Socket.connect(Unknown Source)
> > > > >    at
> > > > com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:232)
> > > > >    at
> > com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:189)
> > > > >    at
> > > com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1250)
> > > > >    ... 75 more
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message