archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: metadata -updater does not appear to be working!
Date Tue, 08 Apr 2008 23:33:51 GMT
On 09/04/2008, Jason Chaffee <jason_chaffee@tvworks.com> wrote:
> 1) touching the old jar, seems to work.

ok, I'll add that info to the bug

>
>  2) I add new builds with maven and not Archiva, and it will increment
>  from the last build number so the next build will not be 4, it will be
>  6.  If, the metatdata file isn't updated first.

right - but if the metadata is up to date, then there's no problem?
That is, are there scenarios other than deleting builds where the
metadata is not updated?

>
>
>  -----Original Message-----
>  From: Brett Porter [mailto:brett.porter@gmail.com]
>
> Sent: Tuesday, April 08, 2008 4:08 PM
>  To: archiva-users@maven.apache.org
>  Subject: Re: metadata -updater does not appear to be working!
>
>  Ah, sorry I wasn't clear. I was referring to the timestamp on the
>  filesystem - if you touch the JAR you listed and scan again, is the
>  metadata updated?
>
>  Likewise, does adding a new build instead of removing work?
>
>  - Brett
>
>  On 09/04/2008, Jason Chaffee <jason_chaffee@tvworks.com> wrote:
>  > I can confirm that both timestamp and build number are the problem.
>  >
>  >  For example, here is the latest artifact on the file system:
>  >
>  >         test-1.0-2008407.211352-3.jar
>  >
>  >  here is the metatdata file:
>  >
>  >         <metadata>
>  >           <groupId>chaffee.jason.test</groupId>
>  >           <artifactId>test</artifactId>
>  >           <version>1.0-SNAPSHOT</version>
>  >           <versioning>
>  >             <snapshot>
>  >               <buildNumber>5</buildNumber>
>  >               <timestamp>20080407.212453</timestamp>
>  >           </snapshot>
>  >           <lastUpdated>20080407212454</lastUpdated>
>  >         </versioning>
>  >       </metadata>
>  >
>  >
>  >
>  >  -----Original Message-----
>  >  From: Brett Porter [mailto:brett.porter@gmail.com]
>  >
>  > Sent: Tuesday, April 08, 2008 3:54 PM
>  >  To: archiva-users@maven.apache.org
>  >  Subject: Re: metadata -updater does not appear to be working!
>  >
>  >
>  > On 09/04/2008, Jason Chaffee <jason_chaffee@tvworks.com> wrote:
>  >  > I will file it today.  Is there any chance of getting it into a
>  1.0.2
>  >  >  release?
>  >
>  >  This is being released now, but there's no reason we can't get
>  another
>  >  release together soon if there are high priority issues.
>  >
>  >  > I know that this is extremely important to us.  I would even
>  >  >  be willing to contribute to with some general guidance where in
>  the
>  >  code
>  >  >  to get started?
>  >
>  >  Hmm, looking at [1] (updateMetadata for VersionReference) it appears
>  >  that it already does calculate the snapshot version. But the code
>  that
>  >  calls it in [2] does include a timestamp check that then skips it.
>  Can
>  >  you confirm whether the timestamp check is the problem?
>  >
>  >  - Brett
>  >
>  >  [1]
>  >
>  http://svn.apache.org/viewvc/archiva/branches/archiva-1.0.x/archiva-base
>  >
>  /archiva-repository-layer/src/main/java/org/apache/maven/archiva/reposit
>  >  ory/metadata/MetadataTools.java?revision=642426&view=markup
>  >  [2]
>  >
>  http://svn.apache.org/viewvc/archiva/branches/archiva-1.0.x/archiva-base
>  >
>  /archiva-consumers/archiva-core-consumers/src/main/java/org/apache/maven
>  >
>  /archiva/consumers/core/MetadataUpdaterConsumer.java?revision=642426&vie
>  >  w=markup
>  >
>  >  --
>  >  Brett Porter
>  >  Blog: http://blogs.exist.com/bporter/
>  >
>
>
>  --
>  Brett Porter
>  Blog: http://blogs.exist.com/bporter/
>


-- 
Brett Porter
Blog: http://blogs.exist.com/bporter/

Mime
View raw message