archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Chaffee" <jason_chaf...@tvworks.com>
Subject RE: metadata -updater does not appear to be working!
Date Tue, 08 Apr 2008 22:43:40 GMT
I will file it today.  Is there any chance of getting it into a 1.0.2
release?  I know that this is extremely important to us.  I would even
be willing to contribute to with some general guidance where in the code
to get started?

-----Original Message-----
From: Brett Porter [mailto:brett.porter@gmail.com] 
Sent: Tuesday, April 08, 2008 3:36 PM
To: archiva-users@maven.apache.org
Subject: Re: metadata -updater does not appear to be working!

Hi Jason,

Can you file this as a request? I think at present the updater
corrects the <versions> flag, but not the snapshot information (it
also doesn't correct the plugin group metadata).

- Brett

On 09/04/2008, Jason Chaffee <jason_chaffee@tvworks.com> wrote:
> According to the documentation the metadata-updater will do the
>  following:
>
>
>
>  metadata-updater - Updates artifact metadata files depending on the
>  content of the repository.
>
>
>
>  I have been testing this by deploying several artifacts to the
>  repository and getting a specific timestamp and build number in the
>  maven-metatadata.xml file.  Next, I delete the latest (snapshot)
build
>  from the repo, including checksums.  I run the repository scanner and
>  the database-updater and this file is never fixed based on the actual
>  contents of the file system.  Archive updates it internal metadata,
but
>  not maven's metadata and thus maven fails to download the artifact.
>
>


-- 
Brett Porter
Blog: http://blogs.exist.com/bporter/

Mime
View raw message