archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: archiva on maestro bring 409 error: Parent doesn't exist during upload of archetype
Date Tue, 25 Mar 2008 10:04:20 GMT
The issue is fixed in later versions of Maestro (1.4+) and Archiva (1.0+).

As a workaround, you need to make the parent directories before deploying.

Cheers,
Brett

On 25/03/2008, David Delbecq <delbd@oma.be> wrote:
> Hello,
>
>  am trying to find out what i did wrong with my archiva config. Am using
>  Archiva bundled in maestro 1.3.1 (pom.properties:
>  version=1.0-maestro-1.3.1). Everytime i try tu upload to repositories, i
>  get 409 error. Sniffing bring this response from server:
>
>  HTTP/1.1 409 Conflict
>  Date: Tue, 25 Mar 2008 07:30:33 GMT
>  Server: Jetty/5.1.10 (Linux/2.6.15-26-386 i386 java/1.5.0_14
>  DAV: 1
>  MS-Author-Via: DAV
>  Content-Type: text/html; charset="UTF-8"
>  Transfer-Encoding: chunked
>
>  b93
>  <html>
>  <head><title>Error 409 Conflict</title></head>
>  <body>
>  <p><b>Error 409 Conflict</b></p>
>  <p>Resource in error: <a
>  href="http://rmibeta.oma.be:9090/archiva/repository/be/meteo/intranet/support/RMI-support-support/1.0-SNAPSHOT/RMI-support-support-1.0-20080325.082723-1.pom/be/meteo/intranet/support/RMI-support-support/1.0-SNAPSHOT/RMI-support-support-1.0-20080325.082723-1.pom">
>  http://rmibeta.oma.be:9090/archiva/repository/be/meteo/intranet/support/RMI-support-support/1.0-SNAPSHOT/RMI-support-support-1.0-20080325.082723-1.pom/be/meteo/intranet/support/RMI-support-support/1.0-SNAPSHOT/RMI-support-support-1.0-20080325.082723-1.pom</a></p>
>  <hr /><p>Exception details:</p>
>  <pre>it.could.webdav.DAVException: Parent doesn't exist
>  .at it.could.webdav.DAVResource.write(DAVResource.java:465)
>  .at it.could.webdav.methods.PUT.process(PUT.java:59)
>  .at it.could.webdav.DAVProcessor.process(DAVProcessor.java:79)
>  .at
>  org.codehaus.plexus.webdav.simple.SimpleDavServerComponent.process(SimpleDavServerComponent.java:152)
>  ....
>
>
>  This seems related to bug report
>  http://jira.codehaus.org/browse/MRM-408, which is supposedly fixed at
>  10/Aug/07 03:34 AM but it seems to still occur. Any suggestion around?
>
>
>  --
>  David Delbecq
>  Institut Royal Météorologique
>  Ext:557
>
>


-- 
Brett Porter
Blog: http://blogs.exist.com/bporter/

Mime
View raw message