archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maria Odea Ching" <och...@apache.org>
Subject Re: Unable to find project model
Date Mon, 31 Mar 2008 09:08:09 GMT
On Mon, Mar 31, 2008 at 4:25 PM, hackaton <hackaton-nabble@yahoo.com> wrote:

>
> I am using Archiva 1.0.1
>
> I got the following error while I tried to browse the ant-1.6.5.jar
> "Unable to find project model for [ant:ant:1.6.5]."
>
> The ant-1.6.5.pom was actually there and it came from
> http://repo1.maven.org/maven2/ant/ant/1.6.5/, but Archiva seem unable to
> parse the ant-1.6.5.pom. The following error was captured in the Archiva's
> "Report":
>
> Error on line 1 of document: The prefix "xsi" for attribute
> "xsi:schemaLocation" associated with an element type "project" is not
> bound.
> Nested exception: The prefix "xsi" for attribute "xsi:schemaLocation"
> associated with an element type "project" is not bound.
>
>
> This is what the ant-1.6.5.pom line 1 looks like:
>    <project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/maven-v4_0_0.xsd">
>
> Other errors such as followings were also found in Archiva' "Report"
> org / apache / maven / maven-artifact / 2.0.8
> File maven-artifact-2.0.8.pom has an invalid project model
> [groupId:
> org.apache.maven|artifactId:maven-artifact|version:2.0.6|packaging:null];
> The model version [2.0.6] does not match the version portion of the
> filename: 2.0.8
>
> For this error, I guess Archiva complains about "package" attribute is
> missing in maven-artifact-2.0.8.pom


I think it's complaining of the mismatched versions.. the version set in the
pom is '2.0.6' while in the filename it's '2.0.8'.


>
>
> Is there anyway to get rid of these errors? or I should just ignore them?


The only way to get rid of these errors is to fix the pom files, but i think
archiva 1.0.1 has a bug of not updating or reflecting the changes
in the poms. Please see..

http://jira.codehaus.org/browse/MRM-608
http://jira.codehaus.org/browse/MRM-622

These two issues have already been fixed though, and will be included in the
next release.


Thanks,
Deng

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message