archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ben short" <jamin.sh...@gmail.com>
Subject Archiva 1.0.1
Date Mon, 11 Feb 2008 22:17:22 GMT
Hi,

Im trying to setup Archiva at work. I havent change any of the default
configuration but when I run mvn clean on my project it fails to find
the following plugin.

<groupId>org.jvnet.jaxb1.maven2</groupId>
<artifactId>maven-jaxb1-plugin</artifactId>
<version>1.0-rc11</version>

And its available at the following URL..

http://download.java.net/maven/2/org/jvnet/jaxb1/maven2/maven-jaxb1-plugin/1.0-rc11/

Which as far as I can see is should be accessable via the "Java.net
Repository for Maven 2" Remote proxy.

I have the following profile in my settings.xml

<profile>
<id>work</id>
  <repositories>
    <repository>
      <id>internal</id>
      <name>Archiva Managed Internal Repository</name>
      <url>http://10.10.10.9:8099/archiva/repository/internal</url>
      <releases>
        <enabled>true</enabled>
      </releases>
      <snapshots>
        <enabled>false</enabled>
      </snapshots>
    </repository>
    <repository>
      <id>snapshots</id>
      <name>Archiva Managed Snapshot Repository</name>
      <url>http://10.10.10.9:8099/archiva/repository/snapshots</url>
      <releases>
        <enabled>false</enabled>
      </releases>
      <snapshots>
        <enabled>true</enabled>
      </snapshots>
    </repository>
  </repositories>
</profile>

Here is the output I get when I try a mvn clean..

E:\Development\Work\rtti-ldb-ws-domain\trunk>mvn clean
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building rtti live departure boards domain
[INFO]    task-segment: [clean]
[INFO] ------------------------------------------------------------------------
Downloading: http://10.10.10.9:8099/archiva/repository/internal/org/jvnet/jaxb1/maven2/maven-jaxb1-plugin/1.0-rc11/maven-jaxb1-plugin-1.0-rc11.pom
Downloading: http://10.10.10.9:8099/archiva/repository/internal/org/jvnet/jaxb1/maven2/maven-jaxb1-plugin/1.0-rc11/maven-jaxb1-plugin-1.0-rc11.pom
Downloading: http://10.10.10.9:8099/archiva/repository/internal/org/jvnet/jaxb1/maven2/maven-jaxb1-plugin/1.0-rc11/maven-jaxb1-plugin-1.0-rc11.pom
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.jvnet.jaxb1.maven2:maven-jaxb1-plugin

Reason: POM 'org.jvnet.jaxb1.maven2:maven-jaxb1-plugin' not found in
repository: Unable to download the artifact from any repository

  org.jvnet.jaxb1.maven2:maven-jaxb1-plugin:pom:1.0-rc11

from the specified remote repositories:
  snapshots (http://10.10.10.9:8099/archiva/repository/snapshots),
  internal (http://10.10.10.9:8099/archiva/repository/internal),
  central (http://repo1.maven.org/maven2)
 for project org.jvnet.jaxb1.maven2:maven-jaxb1-plugin


[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 second
[INFO] Finished at: Mon Feb 11 22:14:38 GMT 2008
[INFO] Final Memory: 2M/6M
[INFO] ------------------------------------------------------------------------

Can anyone give me an idea of what I need todo to get Archiva to
download this plugin?

Mime
View raw message