archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James William Dumay <ja...@atlassian.com>
Subject RE: Archiva crashes after a couple of days
Date Mon, 25 Feb 2008 01:35:02 GMT
We have a similar amount of data in our Archiva instance.

Are you running Archiva on the internal derby database or another dbms? 

Also, try turning off a few of the consumers and see if that helps -
some of the consumers seem not to be handling large datasets gracefully.

James


On Fri, 2008-02-22 at 16:39 -0800, Jason Chaffee wrote:
> They are pretty big, both in number of artifacts and in size.  Our
> largest repo has around 75,000 artifacts in right now and the size is
> over 200 GB.  This is a snapshot repo and we have many teams that are
> creating large installer artifacts that are basically uber artifacts,
> thus the size of these artifacts can be quite large.
> 
> -----Original Message-----
> From: Eric Miles [mailto:eric.miles@kronos.com] 
> Sent: Friday, February 22, 2008 1:38 PM
> To: archiva-users@maven.apache.org
> Subject: RE: Archiva crashes after a couple of days
> 
> We use:
> 
> 0 30 2 * * ? - daily at 2:30 am
> 0 30 * * * ? - every 30 mins
> 
> The default out of the box shouldn't be an issue I wouldn't think.  How
> large are your repos?
> 
> Ours:
> 344M    jasper
> 332K    plugins
> 203M    proxied
> 107M    releases
> 239M    snapshots
> 
> 
> On Fri, 2008-02-22 at 13:28 -0800, Jason Chaffee wrote:
> > I am using the defaults, out of box expressions.  So, it seems those
> too
> > could be fine tuned.
> > 
> > -----Original Message-----
> > From: Brown, Carlton [mailto:Carlton.Brown@compucredit.com] 
> > Sent: Friday, February 22, 2008 1:14 PM
> > To: archiva-users@maven.apache.org
> > Subject: RE: Archiva crashes after a couple of days
> > 
> > > -----Original Message-----
> > > From: Eric Miles [mailto:eric.miles@kronos.com]
> > > Sent: Friday, February 22, 2008 4:07 PM
> > > To: archiva-users@maven.apache.org
> > > Subject: RE: Archiva crashes after a couple of days
> > > 
> > > I too had this same issue.  Make sure your cron syntax is correct as
> > it
> > > is not standard unix cron syntax.  The first entry is a second
> number,
> > > not minutes.  I initially (and accidentally) setup our cron jobs to
> > run
> > > at a crazy pace, I think every second.
> > 
> > Me three.  I didn't see any reason not to scan every minute, but in
> fact
> > it was every second.  Result - massive log files, Archiva hung.  Did
> not
> > have to reinstall it, though.
> > 
> > The cron setup would be a good candidate for improved input forms
> and/or
> > validation.
> > 
> > -----------------------------------------
> > ====================================================
> > This message contains PRIVILEGED and CONFIDENTIAL
> > information that is intended only for use by the 
> > named recipient. If you are not the named recipient,
> > any disclosure, dissemination, or action based on 
> > the contents of this message is prohibited. In such
> > case please notify us and destroy and delete all 
> > copies of this transmission.  Thank you.
> > ====================================================


Mime
View raw message