archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nicolas de loof" <nico...@apache.org>
Subject Re: Trouble with "ejbs" folder and maven1 proxy
Date Fri, 18 Jan 2008 13:56:42 GMT
This issue has been reported recently.

It requires a fix in archiva code to enhance the "type" folder used by
maven1. The current code use the file extension to select the folder, with
few exceptions, but "ejb" type is not correctly supported.

Nico.

2008/1/18, Henrik Brautaset Aronsen <henrik+archiva@nordiclottery.com>:
>
> I recently tried switching from maven-proxy to archiva.
>
> I have installed archiva in http://myhost:9876/archiva/ and my maven1
> repo is accessible from http://myhost:9876/archiva/repository/my-maven1/
>
> Everything seems to work OK, except for one weird thing:
>
> If I try accessing e.g. ...
>
>
> http://myhost:9876/archiva/repository/my-maven1/myproject/ejbs/accounting-ejb-0.2.jar
>
> .. I receive a 404 Not Found with a link to ...
>
> http://myhost:9876/repository/myproject/jars/accounting-ejb-0.2.jar
>
> This only happens when accessing something in the "ejbs" folder.  E.g.
>
> http://myhost:9876/archiva/repository/my-maven1/myproject/jars/backend-dao-0.11.jar
> works fine.
>
> The file permissions are the same all over the repo.  If I switch back
> to use maven-proxy, access to files in the ejbs folder works again.
>
> Henrik
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message