archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sgargan <sgar...@qualcomm.com>
Subject Re: [archiva 1] issue with repository location on disk.
Date Tue, 15 Jan 2008 20:07:53 GMT

If you want it to resolve the appserver.base property, you need to set it.
This wiki entry explains

http://docs.codehaus.org/display/MAVENUSER/Archiva+on+Tomcat




Wendy Smoak-3 wrote:
> 
> On Jan 14, 2008 4:31 PM, Mick Knutson <mickknutson@gmail.com> wrote:
> 
>> In my repository  setup page I have this declaration:
>>
>> Identifier internal  Name Archiva Managed Internal Repository  Directory
>> ${
>> appserver.base}/data/repositories/internal
>>
>> I was assuming that ${appserver.base} would get translated on the fly,
>> but
>> instead, my repository is located at:
>>
>> /home/dapadmin/apache-tomcat-5.5.25/bin/*${appserver.base}*
>> /data/repositories/internal/
>>
>> when I would assume that it should be at:
>>
>> */home/dapadmin/apache-tomcat-5.5.25/bin/*data/repositories/internal/
> 
> ${appserver.base} and ${appserver.home} are Plexus-related properties.
> 
> You seem to be running the Archiva war in Tomcat, so I would suggest
> configuring it with the full path to the location you want to use.
> (Somewhere outside the Tomcat installation would be better...)
> 
> -- 
> Wendy
> 
> 

-- 
View this message in context: http://www.nabble.com/-archiva-1--issue-with-repository-location-on-disk.-tp14819846p14845576.html
Sent from the archiva-users mailing list archive at Nabble.com.


Mime
View raw message