archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: Error 500 accessing snapshots in repository
Date Wed, 12 Dec 2007 09:13:10 GMT
I think I saw this occurring but that there were some specific locks
added to prevent it - is this with Archiva 1.0?

Does it keep occurring after restart? Every time?

If so - perhaps we could capture the index to see what might be the problem.

- Brett

On 12/12/2007, Arnaud Bailly <abailly@oqube.com> wrote:
>
> Hello,
> When using the <Browse> button to navigate through our archiva repositories,
> we cannot access snapshots for home deployed artifacts: an error 500 is
> raised in HTTP and we have the following trace in the server:
>
> 12 dÚc. 2007 09:52:29 org.mortbay.jetty.servlet.ServletHandler handle
> ATTENTION:
> /archiva/browse/com.alu.ebg.commons.prod.mvn.plugins/commons-clearca
> e-ucm-plugin/1.0.000-20071210.150338-5:
> java.lang.NullPointerException
>         at
> org.apache.lucene.index.IndexModifier.close(IndexModifier.java:486)
>         at
> org.apache.maven.archiva.indexer.lucene.LuceneRepositoryContentIndex
> closeQuietly(LuceneRepositoryContentIndex.java:416)
>         at
> org.apache.maven.archiva.indexer.lucene.LuceneRepositoryContentIndex
> modifyRecord(LuceneRepositoryContentIndex.java:152)
>         at
> org.apache.maven.archiva.consumers.lucene.IndexArtifactConsumer.proc
> ssArchivaArtifact(IndexArtifactConsumer.java:118)
>         at
> org.apache.maven.archiva.database.updater.ProcessArchivaArtifactClos
> re.execute(ProcessArchivaArtifactClosure.java:52)
>         at
> org.apache.commons.collections.CollectionUtils.forAllDo(CollectionUt
> ls.java:388)
>         at
> org.apache.maven.archiva.database.updater.JdoDatabaseUpdater.updateU
> processed(JdoDatabaseUpdater.java:152)
>         at
> org.apache.maven.archiva.database.browsing.DefaultRepositoryBrowsing
> selectVersion(DefaultRepositoryBrowsing.java:124)
>         at
> org.apache.maven.archiva.web.action.ShowArtifactAction.artifact(Show
> rtifactAction.java:105)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl
> java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcce
> sorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:597)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invokeAction(DefaultA
> tionInvocation.java:358)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invokeActionOnly(Defa
> ltActionInvocation.java:218)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invoke(DefaultActionI
> vocation.java:192)
>         at
> com.opensymphony.xwork.interceptor.DefaultWorkflowInterceptor.doInte
> cept(DefaultWorkflowInterceptor.java:175)
>         at
> com.opensymphony.xwork.interceptor.MethodFilterInterceptor.intercept
> MethodFilterInterceptor.java:86)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invoke(DefaultActionI
> vocation.java:190)
>         at
> com.opensymphony.xwork.validator.ValidationInterceptor.doIntercept(V
> lidationInterceptor.java:115)
>         at
> com.opensymphony.xwork.interceptor.MethodFilterInterceptor.intercept
> MethodFilterInterceptor.java:86)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invoke(DefaultActionI
> vocation.java:190)
>         at
> org.apache.maven.archiva.web.interceptor.ConfigurationInterceptor.in
> ercept(ConfigurationInterceptor.java:53)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invoke(DefaultActionI
> vocation.java:190)
>         at
> org.codehaus.plexus.redback.xwork.interceptor.PolicyEnforcementInter
> eptor.intercept(PolicyEnforcementInterceptor.java:149)
>         at
> com.opensymphony.xwork.DefaultActionInvocation.invoke(DefaultActionI
> vocation.java:190)
>  ..... [lot more stack trace]
>
>
> I did a repository scan before this.
>
> Regards,
>
> Arnaud Bailly
> --
> View this message in context: http://www.nabble.com/Error-500-accessing-snapshots-in-repository-tp14291277p14291277.html
> Sent from the archiva-users mailing list archive at Nabble.com.
>
>


-- 
Brett Porter
Blog: http://www.devzuz.org/blogs/bporter/

Mime
View raw message