archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: Repository scanning problem in 1.0?
Date Thu, 29 Nov 2007 13:25:40 GMT
On Nov 29, 2007 6:07 AM, ArneD <public@degenring.de> wrote:

> After starting up a fresh instance with default configuration, I copied
> parts of my existing repository to Archiva's default internal repository.
> Then I used the "Scan Repository Now" button on the repository
> administration page. Afterwards, all artifacts were visible on the "Browse"
> page. So far so good.
>
> I then copied some more groups of my existing repo to Archiva's default
> internal repository, and used "Scan Repository Now" once again. But this
> time, the "Browse" page did not show the newly added groups. This was quite
> surprising, as the log output of RepositoryScanner clearly showed that
> Archiva DID walk over these new artifacts, without errors or warnings. I
> tried to use the "Update Database Now" button, but still no effect.
>
> I finally touched one of the POM files in the missing groups, i.e. I gave
> the POM file a new timestamp. After doing "Scan Repository Now" again, the
> artifact appeared on the Browse page. When browsing into the artifact,
> however, I get the error message "Unable to find project model for [...]".

I've seen "Unable to find project model for [...]" in recent versions
of Archiva, also using with existing repository contents, but have not
been able to isolate it with publicly available repo data.

Can you come up with steps to reproduce this, and attach zipped
repository contents to a JIRA issue?  It shouldn't take more than a
few artifacts to provoke the problem, once you know the cause.
http://jira.codehaus.org/browse/MRM

Thanks,
-- 
Wendy

Mime
View raw message