archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ArneD <pub...@degenring.de>
Subject Repository scanning problem in 1.0?
Date Thu, 29 Nov 2007 13:07:36 GMT

Hi all,

first of all, congratulations to all Archiva developers for releasing the
1.0 version!

I started playing around with it a little bit, and ran into the following
problem:

After starting up a fresh instance with default configuration, I copied
parts of my existing repository to Archiva's default internal repository.
Then I used the "Scan Repository Now" button on the repository
administration page. Afterwards, all artifacts were visible on the "Browse"
page. So far so good.

I then copied some more groups of my existing repo to Archiva's default
internal repository, and used "Scan Repository Now" once again. But this
time, the "Browse" page did not show the newly added groups. This was quite
surprising, as the log output of RepositoryScanner clearly showed that
Archiva DID walk over these new artifacts, without errors or warnings. I
tried to use the "Update Database Now" button, but still no effect. 

I finally touched one of the POM files in the missing groups, i.e. I gave
the POM file a new timestamp. After doing "Scan Repository Now" again, the
artifact appeared on the Browse page. When browsing into the artifact,
however, I get the error message "Unable to find project model for [...]".

Seems like a bug to me? I know that my playground scenario may be a little
bit unusual, but I would expect that Archiva should always be able to
synchronize itself to the file system contents, regardless of the files'
timestamps.

Thanks
- Arne

-- 
View this message in context: http://www.nabble.com/Repository-scanning-problem-in-1.0--tf4897121.html#a14025501
Sent from the archiva-users mailing list archive at Nabble.com.


Mime
View raw message