archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joakim Erdfelt <joa...@erdfelt.com>
Subject Re: Archiva build failure on missing archiva applet
Date Thu, 04 Oct 2007 17:13:44 GMT
Dietrich,

A few tips.
* Compile using JDK 1.5 (Use 1.5.0_10 or newer)
* Use maven 2.0.5 or newer (most of the devs use maven 2.0.7)
* Compile using [archiva/trunk]$ mvn clean install

You *must* use the install phase in order for the build to find its 
dependencies.

Now about the failed tests ...
Can you zip up the contents of your target/surefire-reports/* for any 
module you detect a build failure on and attach it to the following 
issue ticket?
http://jira.codehaus.org/browse/MRM-514

We are very aggressive with fixing any testing issues that crop up, and 
all of the developers run unit tests on every build with their machines 
(a varied mix of WinXP, Linux, and OSX).
We also have a Continuum instance set up to build / test archiva when 
new code is detected in the subversion repository.

Now, as for the HTTP 507 issue.
That's been fixed in the past 2 weeks in archiva/trunk.
See http://jira.codehaus.org/browse/MRM-243

- Joakim

Dietrich Schulten wrote:
> I'm trying to get the fix for the HTTP 507 webdav error in 1.0-beta-2
> running, therefore I built the current version from svn.
> I ran into the same test problem as Arent-Jan Banck, so I ran mvn
> compile only (Probably solvable with JDK 1.6).
>
> But I'm stuck here:
>
>
> [INFO] [dependency:copy {execution: copy}]
> [INFO] Configured Artifact:
> org.apache.maven.archiva:archiva-applet:null:1.0-bet
> a-3-SNAPSHOT:jar
> [INFO] snapshot
> org.apache.maven.archiva:archiva-applet:1.0-beta-3-SNAPSHOT: che
> cking for updates from codehaus.snapshots
> [INFO] snapshot
> org.apache.maven.archiva:archiva-applet:1.0-beta-3-SNAPSHOT: che
> cking for updates from maven2-repository.dev.java.net
> [INFO] snapshot
> org.apache.maven.archiva:archiva-applet:1.0-beta-3-SNAPSHOT: che
> cking for updates from apache.snapshots
> Downloading:
> http://snapshots.repository.codehaus.org//org/apache/maven/archiva/
> archiva-applet/1.0-beta-3-SNAPSHOT/archiva-applet-1.0-beta-3-SNAPSHOT.jar
> Downloading:
> http://download.java.net/maven/2//org/apache/maven/archiva/archiva-
> applet/1.0-beta-3-SNAPSHOT/archiva-applet-1.0-beta-3-SNAPSHOT.jar
> Downloading:
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/mav
> en/archiva/archiva-applet/1.0-beta-3-SNAPSHOT/archiva-applet-1.0-beta-3-SNAPSHOT
> .jar
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Unable to find artifact.
>
> Embedded error: Unable to download the artifact from any repository
>
> Try downloading the file manually from the project website.
>
> Then, install it using the command:
>     mvn install:install-file -DgroupId=org.apache.maven.archiva
> -DartifactId=arc
> hiva-applet \
>         -Dversion=1.0-beta-3-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
> Alternatively, if you host your own repository you can deploy the file
> there:
>   mvn deploy:deploy-file -DgroupId=org.apache.maven.archiva
> -DartifactId=archiva
> -applet \
>         -Dversion=1.0-beta-3-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file \
>          -Durl=[url] -DrepositoryId=[id]
>
>
>   org.apache.maven.archiva:archiva-applet:jar:1.0-beta-3-SNAPSHOT
>
> from the specified remote repositories:
>   codehaus.snapshots (http://snapshots.repository.codehaus.org/),
>   apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>   maven2-repository.dev.java.net (http://download.java.net/maven/2/),
>   central (http://repo1.maven.org/maven2)
>
>   


Mime
View raw message