archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Campbell, Jeff" <Jeff_Campb...@intuit.com>
Subject Errors using Archiva as a proxy
Date Wed, 12 Sep 2007 18:13:08 GMT
I downloaded the latest version of Archiva (1.0 Beta 1)

 

I run Archiva from
\apache-archiva-1.0-beta-1-bin\apache-archiva-1.0-beta-1\bin\windows-x86
-32

 

In my settings.xml file I put the following:

         <mirrors>

        <mirror>

            <id>archiva</id>

            <name>Archiva Mirror</name>

            <mirrorOf>central</mirrorOf>

 
<url>http://localhost:8080/archiva/repository/internal/</url>

        </mirror>

    </mirrors>

 

 

After I have done this and run a "mvn install" on a simple project (and
I have NO local cache) I get the following from my build:

[INFO] Scanning for projects...

[INFO]
------------------------------------------------------------------------
----

[INFO] Building Code Generator

[INFO]    task-segment: [install]

[INFO]
------------------------------------------------------------------------
----

[INFO] artifact org.apache.maven.plugins:maven-resources-plugin:
checking for updates from soupbowl.mvnrepo

[INFO] artifact org.apache.maven.plugins:maven-resources-plugin:
checking for updates from central

[WARNING] repository metadata for: 'artifact
org.apache.maven.plugins:maven-resources-plugin' could not be retrieved
fro

m repository: central due to an error: Error transferring file

[INFO] Repository 'central' will be blacklisted

[INFO]
------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO]
------------------------------------------------------------------------

[INFO] The plugin 'org.apache.maven.plugins:maven-resources-plugin' does
not exist or no valid version could be found

[INFO]
------------------------------------------------------------------------

[INFO] For more information, run Maven with the -e switch

[INFO]
------------------------------------------------------------------------

[INFO] Total time: 1 second

[INFO] Finished at: Wed Sep 12 11:58:26 MDT 2007

[INFO] Final Memory: 1M/4M

[INFO]
------------------------------------------------------------------------

 

 

 

 

 

>From the Archiva window I get the following error:

 

jvm 1    | 2007-09-12 11:38:49,204 [SocketListener0-1] WARN
org.codehaus.plexus.redback.authentication.Authenticator:us

er-manager  - Login for user mvn failed. user not found.

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:56 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:57 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:57 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:57 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:39:57 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: Initializing
org.codehaus.plexus.webdav.simple.SimpleDavServerComponent

jvm 1    | Sep 12, 2007 11:40:20 AM
org.mortbay.jetty.servlet.ServletHandler$Context log

jvm 1    | INFO: RepositoryServlet: Authorization Denied
[ip=127.0.0.1,isWriteRequest=false,permission=archiva-read-repo

sitory,repo=internal] : no matching permissions

 

 

 

If I open a web browser to the following URL:
://localhost:8080/archiva/repository/internal/ I get a prompt to enter a
username and password.  If I put one of my usernames in (that I setup
from the Archiva UI), then it will log me in.

 

 

What am I doing wrong?  Do I have to create a "mvn" user in Archiva to
allow a "mvn install" to be performed?  Can I remove the requirement to
have to use a username and password?  Am I just doing everything wrong?

 

Thanks,

Jeff

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message