archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendell <wbeckw...@binyan.org>
Subject Re: Can't build Archive latest due to archive-proxy
Date Sun, 01 Apr 2007 20:07:50 GMT

It's working now although the only 3 changes I have made is to update to
maven 2.0.6, wipe out and let the new maven rebuild the repo and I updated
the jdk to java 6 update 1.  None of those changes should have affected the
building but that's a mystery for another time.

Wb


Emmanuel Venisse wrote:
> 
> The build worked fine for lot of us, but with the latest fix, it should
> build fine for you too.
> 
> Emmanuel
> 
> Wendell a écrit :
>> I've been getting failed builds with Archiva since last night for the
>> following error in the archiva-proxy project.
>> 
>> Test set: org.apache.maven.archiva.proxy.ProxyRequestHandlerTest
>> -------------------------------------------------------------------------------
>> Tests run: 64, Failures: 0, Errors: 64, Skipped: 0, Time elapsed: 0.331
>> sec
>> <<< FAILURE!
>> testGetDefaultLayoutNotPresent(org.apache.maven.archiva.proxy.ProxyRequestHandlerTest)

>> Time elapsed: 0.041 sec  <<< ERROR!
>> java.lang.NoSuchMethodError:
>> org.codehaus.plexus.PlexusContainer.setConfigurationResource(Ljava/io/Reader;)V
>> 	at org.codehaus.plexus.PlexusTestCase.setUp(PlexusTestCase.java:116)
>> 	at
>> org.apache.maven.archiva.proxy.ProxyRequestHandlerTest.setUp(ProxyRequestHandlerTest.java:98)
>> 	at junit.framework.TestCase.runBare(TestCase.java:125)
>> 	at junit.framework.TestResult$1.protect(TestResult.java:106)
>> 	at junit.framework.TestResult.runProtected(TestResult.java:124)
>> 	at junit.framework.TestResult.run(TestResult.java:109)
>> 	at junit.framework.TestCase.run(TestCase.java:118)
>> 	at junit.framework.TestSuite.runTest(TestSuite.java:208)
>> 	at junit.framework.TestSuite.run(TestSuite.java:203)
>> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> 	at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> 	at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> 	at java.lang.reflect.Method.invoke(Method.java:597)
>> 	at
>> org.apache.maven.surefire.junit.JUnitTestSet.execute(JUnitTestSet.java:210)
>> 	at
>> org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:135)
>> 	at
>> org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:122)
>> 	at org.apache.maven.surefire.Surefire.run(Surefire.java:129)
>> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> 	at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> 	at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> 	at java.lang.reflect.Method.invoke(Method.java:597)
>> 	at
>> org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:225)
>> 	at
>> org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:747)
>> 
>> 
>> The problem was reported before @ 
>> http://www.nabble.com/forum/ViewPost.jtp?post=9670861&framed=y
>> http://www.nabble.com/forum/ViewPost.jtp?post=9670861&framed=y , but I
>> did
>> not see a solution however it seems the problem went away for the
>> reporter. 
>> I have tried building the latest as well as rev 521889 that was reported
>> as
>> working.  I have done clean checkouts on both revs as well as wiped the
>> repository for a full repo rebuild.
>> 
>> What can I do to get past this problem and onto the next?
>> 
>> Wb
>> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Can%27t-build-Archive-latest-due-to-archive-proxy-tf3497575.html#a9781630
Sent from the archiva-users mailing list archive at Nabble.com.


Mime
View raw message