archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Sam-Bodden <bsbod...@gmail.com>
Subject Archiva on Tomcat 5.5.20 on a VPS
Date Sat, 10 Mar 2007 06:36:13 GMT
Followed the instructions at  http://maven.apache.org/archiva/guides/ 
getting-started/index.html

I get a 500 error showing:

======================================================================== 
===================================
======================================================================== 
===================================
Connection Factory "java:comp/env/jdbc/archiva" not found - action -  
file:/opt/tomcat5/webapps/archiva/WEB-INF/classes/xwork.xml:176:78
	 
com.opensymphony.xwork.config.providers.XmlConfigurationProvider.verifyA 
ction(XmlConfigurationProvider.java:186)
	 
com.opensymphony.xwork.config.providers.XmlConfigurationProvider.addActi 
on(XmlConfigurationProvider.java:136)
	 
com.opensymphony.xwork.config.providers.XmlConfigurationProvider.addPack 
age(XmlConfigurationProvider.java:220)
	 
com.opensymphony.xwork.config.providers.XmlConfigurationProvider.loadCon 
figurationFile(XmlConfigurationProvider.java:676)
	com.opensymphony.xwork.config.providers.XmlConfigurationProvider.init 
(XmlConfigurationProvider.java:91)
	com.opensymphony.xwork.config.impl.DefaultConfiguration.reload 
(DefaultConfiguration.java:85)
	com.opensymphony.xwork.config.ConfigurationManager.getConfiguration 
(ConfigurationManager.java:54)
	com.opensymphony.xwork.DefaultActionProxy.<init> 
(DefaultActionProxy.java:57)
	com.opensymphony.xwork.DefaultActionProxyFactory.createActionProxy 
(DefaultActionProxyFactory.java:46)
	com.opensymphony.webwork.dispatcher.DispatcherUtils.serviceAction 
(DispatcherUtils.java:216)
	com.opensymphony.webwork.dispatcher.FilterDispatcher.doFilter 
(FilterDispatcher.java:202)
	com.opensymphony.module.sitemesh.filter.PageFilter.parsePage 
(PageFilter.java:118)
	com.opensymphony.module.sitemesh.filter.PageFilter.doFilter 
(PageFilter.java:52)
	com.opensymphony.webwork.dispatcher.ActionContextCleanUp.doFilter 
(ActionContextCleanUp.java:88)
======================================================================== 
===================================
======================================================================== 
===================================

In the catalina.out log I see this errors:

======================================================================== 
===================================
======================================================================== 
===================================
INFO   | jvm 1    | 2007/03/10 01:20:14 | 2007-03-10 01:20:14,752  
[http-8080-Processor5] INFO  EnvironmentCheck:required-roles -  
Checking the existance of required roles.
INFO   | jvm 1    | 2007/03/10 01:20:26 | 2007-03-10 01:20:26,830  
[http-8080-Processor5] ERROR  
Interceptor:pssEnvironmentCheckInterceptor - EnvironmentCheck Failure.
INFO   | jvm 1    | 2007/03/10 01:20:26 |  
======================================================================
INFO   | jvm 1    | 2007/03/10 01:20:26 |  ENVIRONMENT FAILURE !!
INFO   | jvm 1    | 2007/03/10 01:20:26 |
INFO   | jvm 1    | 2007/03/10 01:20:26 | Missing "/security" package  
namespace in xwork.xml
INFO   | jvm 1    | 2007/03/10 01:20:26 | Missing [1] xwork.xml  
configuration elements.
INFO   | jvm 1    | 2007/03/10 01:20:26 |
INFO   | jvm 1    | 2007/03/10 01:20:26 |  
======================================================================
INFO   | jvm 1    | 2007/03/10 01:20:26 | 2007-03-10 01:20:26,864  
[http-8080-Processor5] INFO  Interceptor:pssSecureActionInterceptor -  
org.codehaus.plexus.security.ui.web.interceptor.SecureActionInterceptor  
initialized!
INFO   | jvm 1    | 2007/03/10 01:20:28 | 2007-03-10 01:20:28,444  
[http-8080-Processor5] ERROR VelocityComponent              -  
ResourceManager : unable to find resource 'VM_global_library.vm' in  
any resource loader.
INFO   | jvm 1    | 2007/03/10 01:20:28 | 2007-03-10 01:20:28,748  
[http-8080-Processor5] INFO  Interceptor:pssSecureActionInterceptor -  
org.codehaus.plexus.security.ui.web.interceptor.SecureActionInterceptor  
initialized!
INFO   | jvm 1    | 2007/03/10 01:20:28 | 2007-03-10 01:20:28,750  
[http-8080-Processor5] INFO  Interceptor:pssSecureActionInterceptor -  
org.codehaus.plexus.security.ui.web.interceptor.SecureActionInterceptor  
initialized!
INFO   | jvm 1    | 2007/03/10 01:20:29 | 2007-03-10 01:20:29,620  
[http-8080-Processor5] ERROR DispatcherUtils                - Could  
not find action
INFO   | jvm 1    | 2007/03/10 01:20:29 | Connection Factory  
"java:comp/env/jdbc/archiva" not found - action - file:/opt/tomcat5/ 
webapps/archiva/WEB-INF/classes/xwork.xml:176:78
======================================================================== 
===================================
======================================================================== 
===================================

So it seems that the DataSource never get bound in JNDI. I even tried  
adding what somebody deploying to JBoss did, which is to add:

   <resource-ref>
     <res-ref-name>jdbc/users</res-ref-name>
     <res-type>javax.sql.DataSource</res-type>
     <res-auth>Container</res-auth>
   </resource-ref>

To the archiva web.xml. No luck!

Any ideas?

Thanks,
    Brian

Mime
View raw message