archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Dale <robert.d...@duke.edu>
Subject Re: two 500 errors
Date Sat, 27 Jan 2007 23:19:37 GMT
<div><div><font color="#990099">-----Brett Porter &lt;brett@apache.org&gt;
wrote: -----<br><br></font>&gt;To:&nbsp;archiva-users@maven.apache.org<br>&gt;From:&nbsp;Brett&nbsp;Porter&nbsp;&lt;brett@apache.org&gt;<br>&gt;Date:&nbsp;01/27/2007&nbsp;05:10PM<br>&gt;Subject:&nbsp;Re:&nbsp;two&nbsp;500&nbsp;errors<br>&gt;<br>&gt;<br>&gt;On&nbsp;28/01/2007,&nbsp;at&nbsp;5:41&nbsp;AM,&nbsp;Robert&nbsp;Dale&nbsp;wrote:<br>&gt;<br>&gt;&gt;&nbsp;I'm&nbsp;running&nbsp;the&nbsp;latest&nbsp;svn&nbsp;as&nbsp;of&nbsp;today&nbsp;-&nbsp;500580.<br>&gt;&gt;<br>&gt;&gt;&nbsp;If&nbsp;I&nbsp;try&nbsp;to&nbsp;retrieve&nbsp;a&nbsp;file&nbsp;from&nbsp;the&nbsp;local&nbsp;repository&nbsp;I&nbsp;get&nbsp;this&nbsp;&nbsp;<br>&gt;&gt;&nbsp;error:<br>&gt;&gt;&nbsp;exception<br>&gt;&gt;&nbsp;javax.servlet.ServletException:&nbsp;Unable&nbsp;to&nbsp;lookup&nbsp;role&nbsp;[null]&nbsp;hint&nbsp;&nbsp;<br>&gt;&gt;&nbsp;[basic]<br>&gt;&gt;&nbsp;root&nbsp;cause<br>&gt;&gt;<br>&gt;org.codehaus.plexus.component.repository.exception.ComponentLookupExc<br>&gt;e&nbsp;<br>&gt;&gt;&nbsp;ption:<br>&gt;&gt;&nbsp;Component&nbsp;descriptor&nbsp;cannot&nbsp;be&nbsp;found&nbsp;in&nbsp;the&nbsp;component&nbsp;repository:<br>&gt;&gt;&nbsp;nullbasic&nbsp;(lookup&nbsp;realm:&nbsp;ClassRealm[plexus.xwork,&nbsp;parent:&nbsp;null]).<br>&gt;<br>&gt;What&nbsp;do&nbsp;you&nbsp;mean&nbsp;by&nbsp;'retrieve&nbsp;a&nbsp;file&nbsp;from&nbsp;a&nbsp;local&nbsp;repository'?<br><br>Basically,
hitting the URL under the path /repository/.<br><br>http://host.com/repository/<br>http://host.com/repository/org/<br>http://host.com/repository/org/apache/<br>http://host.com/repository/org/apache/maven/<br>http://host.com/repository/org/apache/maven/maven-project/<br>http://host.com/repository/org/apache/maven/maven-project/2.0.4/<br>http://host.com/repository/org/apache/maven/maven-project/2.0.4/maven-project-2.0.4.pom<br><br>These
all generate the same error<br><br>Does this seem like an Archiva or a server
config issue?<br><br>Does this have to do with basic auth or security realms?<br><br>Thanks,<br>--
<br>Robert Dale<br><br></div></div>
Mime
View raw message