archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hilco Wijbenga" <hilco.wijbe...@gmail.com>
Subject Running Archiva WAR on JBoss 4.0.5
Date Fri, 15 Dec 2006 19:59:50 GMT
Hi all,

I checked out Archiva from Subversion and ran 'mvn clean install'.
This yielded a WAR in archiva-webapp/target. I copied this WAR into
the JBoss deploy directory and requested http://localhost/archiva.

The WAR seems to at least partially deploy but I do get a few
stacktraces. I noticed that it's looking for .m2/security.properties
and .m2/archiva.properties. I don't have these. What should I put in
these properties files?

I can deploy proximity's WAR so I think my JBoss install is ok.

Should I be able to deploy the Archiva WAR like this? Do I need to
do something in the WAR before I deploy it? Set some property during
the build?

The problem appears to be related to the database (i.e. I think it's a
JDBC connection problem).

I also tried to run 'mvn site' in the hopes of finding some info there
but the build fails. :-(

Cheers,
Hilco

P.S. Parts of the stacktraces:
Caught Exception while registering Interceptor class
pssForceAdminUserInterceptor - [unknown location]
        at org.codehaus.plexus.xwork.PlexusObjectFactory.buildInterceptor(PlexusObjectFactory.java:134)
<snip/>
Caused by: org.jpox.exceptions.ConnectionFactoryNotFoundException:
Connection Factory "java:comp/env/jdbc/users" not found
NestedThrowables:
javax.naming.NameNotFoundException: jdbc not bound
        at org.jpox.AbstractPersistenceManagerFactory.lookupDataSource(AbstractPersistenceManagerFactory.java:175)
Caused by: javax.naming.NameNotFoundException: jdbc not bound
        at org.jnp.server.NamingServer.getBinding(NamingServer.java:529)

Mime
View raw message